Results 1 to 2 of 2
  1. #1

    GTI 155 ltd hanging up at 3600 rpm

    Installed a new engine in my 155 and took it out yesterday. I could not get it above 4500 rpm. Checked plugs and looked as if they were not getting fuel to all cyl. Changed injectors just to try that and now it cranks and idols fine but once i hit the throttle it hangs at 3600 rpm. All running today has been on hose. Any help appreciated.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Did you replace the spark plugs?

    Any codes?
    How old is the fuel?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. loading up at low rpms
    By speedy9913 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 09-08-2013, 08:52 AM
  2. Xl1200 ltd not performing at high rpms
    By jetski2000 in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 06-17-2013, 10:54 PM
  3. Replies: 9
    Last Post: 05-06-2011, 07:53 AM
  4. Why is my ski hanging at 3000 rpm?
    By zxiripper in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 07-31-2009, 08:17 PM
  5. 99 GTX Ltd Cutting out at high RPM
    By Picturemn2 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-28-2007, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •