Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1

    76.1 no rings yet

    well i left the gps on so my buddies could have a ride, when i got on it76.1 had been acheaved. bye bill


  2. #2
    xenonx's Avatar
    Join Date
    Feb 2006
    Location
    Woodland Hills, CA
    Posts
    237
    How many RPMs are you turning with the 15-19 3 blade on your setup?

  3. #3

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    i'm at 8550 could be more, the taco stops at 8550, i want to get it at 8500 tried tonight with 81mm ring but no joy still the same, i need to bend the prop more, then see

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,399
    +1
    2,524
    Bill, you are making huge power with that Rude Charger to be able to sling that 15/19 3 blade at 8550 RPM's with an 81mm nozzle

    Start by adding 1 mm pitch

  5. #5

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    i'd rather put 2mm more on, ontop of your 1mm, jerry just as a matter of intrest how much more bending can i do? or would the 4 blade with 2 or 3mms be better ?

  6. #6

    Join Date
    Jan 2006
    Location
    Puerto Rico
    Posts
    691

    Thumbs up

    Quote Originally Posted by jetskibill9999 View Post
    i'm at 8550 could be more, the taco stops at 8550, i want to get it at 8500 tried tonight with 81mm ring but no joy still the same, i need to bend the prop more, then see
    How was the weather?? air, humidity etc... fresh or salt water? do you ride @ sea level? just curious. thanks

    Ray

  7. #7

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by GPR/STX-15F/RXT View Post
    How was the weather?? air, humidity etc... fresh or salt water? do you ride @ sea level? just curious. thanks

    Ray
    yes sea level,salt water, 10c pritty cold really

  8. #8
    Phil's Avatar
    Join Date
    May 2005
    Location
    Smith Mountain Lake, VA
    Posts
    1,428
    +1
    23
    Quote Originally Posted by jetskibill9999 View Post
    well i left the gps on so my buddies could have a ride, when i got on it76.1 had been acheaved. bye bill
    Wow, that is a great speed considering you are not using the EMS system. That Rude supercharger must be doing the trick for you. I also think the sea level and salt water help for about 3mph over my situation which is fresh water @ 800ft. above sea level. A big piece of the puzzle is also the barometer. If you have a nice high pressure day of 31 you could pick up 2-3mph and conversely a low pressure of around 28 could cheat you out of 2-3mph.

    I guess my big question is: How is your acceleration from 0 to 30mph, 0 to 60mph, and 0 to 70mph?

  9. #9

    Join Date
    Jan 2006
    Location
    Puerto Rico
    Posts
    691
    Quote Originally Posted by jetskibill9999 View Post
    yes sea level,salt water, 10c pritty cold really
    That's what i thought, "pritty cold really" thanks for the info

    Ray

  10. #10

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by GPR/STX-15F/RXT View Post
    That's what i thought, "pritty cold really" thanks for the info

    Ray
    i think its slow, i was thinking i might get 79mph, i still have the fine tune to do yet, eg riva grate, 2mm more on prop, but out of the hole is arm wrenching,as we tex my mate has just bought an rxp and is still bringing it home at 0.45am, were getting ready for easter were we've got a bet with the landlord that my 05 gtx ltd, will kill he's stage 1 rxp, i hope it works

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Connecting lanyard to jacket with no ring.
    By hfwb in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 04-27-2014, 06:33 PM
  2. Giving it a try - Driveshaft Seal (no more carbon ring)
    By Shibby1485 in forum 4-Tec Performance
    Replies: 75
    Last Post: 10-20-2007, 06:57 PM
  3. anyone install new black wear rings yet?
    By Pale Rider in forum 4-Tec Performance
    Replies: 31
    Last Post: 08-11-2007, 12:53 AM
  4. I've got the Carbon Ring Line, but no Leaks
    By yellow4 in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-07-2007, 09:31 AM
  5. no changes yet
    By Compwhiz82 in forum Sea Doo Open Discussion
    Replies: 28
    Last Post: 09-22-2005, 09:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •