Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 45
  1. #1
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1

    Guess who joined the 71+mph club...?

    Yup! I did!

    Went to the canal to do some testing after installing the skegs and filled the rideplate holes. I was turning 7950 rpms....then I took the small compartment off and hit 8000-8100 rpms jumping up and down, never stable. I ran constant 71.5mph Out of the hole I cant keep it hooked! I lean forward all the way and helps but not 100%....

    As I was leaving, a newly white painted gp1300 with fancy handlebars pulled up....I was putting in the Yamaha in the trailer after I took it for a ride that yielded 59 mph....Anyways, the guy comes up, gives me his card, seems to fix waveruners and boats....Then he asked about the RXT, I said I had a stage 2+....He said, wanna run...? I said hell yeah! I had only one bar of gas so it had to be quick....He jumped 4-5 boats on me as I could not keep in hooked for a biatch....fast I was jogging by him and left him in the dust numerous times!....He never told me what he had... but sounded mean though

    Porpoising badly after 70....


  2. #2
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    it feels good to have it running the way it should,

    on the holeshot is it jumping out of the water or are you spinning the prop if it is jumping out it may be the wedge I wish you would try it without the wedge and let me know as I have one but have not installed it yet

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    yu go boi !

  4. #4
    xenonx's Avatar
    Join Date
    Feb 2006
    Location
    Woodland Hills, CA
    Posts
    237
    Geo,

    I could never get my RXT to launch well with the wedge. Not only that, I did not like the way it handled nose up going into turns.

    It does sound like you have cavitation. Have you checked the pump area for good seal and or the wear ring/prop condition?

    Maybe time for a Riva/Skat 18-18R? You won't get beat out of the hole with that prop. No cavitation and great acceleration.

    A set of RE blockoffs would help with the porposing...especially with the wedge.

  5. #5
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373

  6. #6
    xenonx's Avatar
    Join Date
    Feb 2006
    Location
    Woodland Hills, CA
    Posts
    237
    Geo,

    See you are still running the Riva air intake. Put that thing up for sale and get the 4" adapter and get 7-8' of 4" Kanoflex. Run it up to the front.
    Remove the front baffle that holds the fire extinguisher on...or drill some decent sized holes in it to get some air flow. Then you can cut out a good deal of the underside of the hood support to promote some air flow through the hull. Some flow-rites at the back under the grap rail couldn't hurt to promote air flow and dicipate engine heat.

    Just an idea.
    The adapter is only $50 or so and the Kanoflex is like $38. Flow-Rites are about $18. Sell your Riva air intake for $150 or so and you come out almost even $ wise with improved performance.

  7. #7

    Join Date
    Jan 2006
    Location
    Puerto Rico
    Posts
    691

    Smile

    [quote=GeoRXT;242443]Yup! I did!

    Went to the canal to do some testing after installing the skegs and filled the rideplate holes. I was turning 7950 rpms....then I took the small compartment off and hit 8000-8100 rpms jumping up and down, never stable. I ran constant 71.5mph Out of the hole I cant keep it hooked! I lean forward all the way and helps but not 100%....

    WOW congrats Geo what did i told you when you talk about your new set-up for the first time in the board??? i knew that your ski was suppose to run over 70 MPH with your mods, now PLEASE give me a favor, throw that #@^*) wedge to the trash and try again OK???


    Porpoising badly after 70....

    If removing the wedge don't stop the porpoising completely, i know a home made trick that do wonders to solve this issue and doesn't hurt your ski top end speed but the mod have to be done by a machine shop but i think that my local tech have some of them in stock in his shop and i may have another spare one in my garage get in touch

    Ray
    Last edited by GPR/STX-15F/RXT; 03-26-2007 at 07:18 PM.

  8. #8

    Join Date
    Jan 2006
    Location
    Puerto Rico
    Posts
    691

    Smile

    [quote=GeoRXT;242443]Yup! I did!

    Went to the canal to do some testing after installing the skegs and filled the rideplate holes. I was turning 7950 rpms....then I took the small compartment off and hit 8000-8100 rpms jumping up and down, never stable. I ran constant 71.5mph Out of the hole I cant keep it hooked! I lean forward all the way and helps but not 100%....

    WOW congrats Geo what did i told you when you talk about your new set-up for the first time in the board??? i knew that your ski was suppose to run over 70 MPH with your mods, now PLEASE give me a favor, throw that #@^*) wedge to the trash and try again OK???


    Porpoising badly after 70....

    If removing the wedge don't stop the porpoising completely, i know a home made trick that do wonders to solve this issue and doesn't hurt your ski top end speed but the mod have to be done by a machine shop but i think that my local tech have some of them in stock in his shop and i think that i have another spare one in my garage get in touch

    Ray

  9. #9
    BOOSTED's Avatar
    Join Date
    Oct 2006
    Location
    ARUBA
    Posts
    359
    Finally getting things together

  10. #10
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,809
    Quote Originally Posted by GeoRXT View Post
    Yup! I did!

    Went to the canal to do some testing after installing the skegs and filled the rideplate holes. I was turning 7950 rpms....then I took the small compartment off and hit 8000-8100 rpms jumping up and down, never stable. I ran constant 71.5mph
    Good job and congrats!!!!! Keep up the good work....

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Finally in the 80 mph club!!!
    By WickedXP in forum 4-Tec Performance
    Replies: 30
    Last Post: 09-20-2014, 10:50 PM
  2. I just joined the 90 MPH club
    By EGGonz in forum Yamaha PWC Performance (4-stroke)
    Replies: 74
    Last Post: 12-12-2010, 07:54 PM
  3. ok who wants to break the 90 mph club?
    By PeteSkeet in forum Kawasaki Open Discussion
    Replies: 13
    Last Post: 04-07-2009, 12:49 PM
  4. I Joined The 70 MPH Club
    By RobbieMWD in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-31-2008, 10:14 PM
  5. Shibby's Week in Review - joined the bad luck club
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 36
    Last Post: 05-16-2007, 10:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •