Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    mattydipps's Avatar
    Join Date
    Mar 2013
    Location
    Babylon, Long Island
    Posts
    652
    +1
    51

    Antifreeze question...

    I'm in the middle of getting my ski all set up for the summer... (New t clamps for all the fittings, new reverse bucket... Misc crap) I was moving around the antifreeze res and I notice there's almost next to no antifreeze inside there after the winter... What gives?? Can I just fill up with regular antifreeze or is there a certain kind I need to use??


  2. #2
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    847
    +1
    93
    Any green mixed 50/50. No dexcool. I use Preston premixed.

  3. #3
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Did you find the source of the leak? Check all clamps and plugs. Any antifreeze laying in your hull? +1 on the 50/50 mix

  4. #4
    tick.. tick.. RXPteamtimebomb's Avatar
    Join Date
    Jan 2007
    Location
    Maryland
    Posts
    726
    +1
    13
    Ride plate bolts on top of the plate leaking any?

  5. #5
    mattydipps's Avatar
    Join Date
    Mar 2013
    Location
    Babylon, Long Island
    Posts
    652
    +1
    51
    I'm going to try and find the leak when I get home.. I saw nothing on the top of the ride plate.. Nothing on my floor around My ski.. Nothing inside the hull.. It almost just disappeared

  6. #6
    infamous's Avatar
    Join Date
    Oct 2010
    Location
    Long Island, NY
    Posts
    2,036
    +1
    336
    You sure it was full when you put it away? Could have been leaking before hand and evaporated already. I dont remember checking any levels when we winterized it. Fill and keep and eye on it.

  7. #7
    mattydipps's Avatar
    Join Date
    Mar 2013
    Location
    Babylon, Long Island
    Posts
    652
    +1
    51
    Quote Originally Posted by STUNNA View Post
    You sure it was full when you put it away? Could have been leaking before hand and evaporated already. I dont remember checking any levels when we winterized it. Fill and keep and eye on it.
    I'm pretty positive it was full (well, at the full line) I'm convinced it was the way I stored the bottle for the winter I almost had it on its side because I didn't put the seat bracket that holds the res straight up and down back in... It must have leaked.. I'll fill and keep a close look at it

  8. #8
    speednutz's Avatar
    Join Date
    Feb 2013
    Location
    winona,mn
    Posts
    264
    +1
    8
    Hopefully not in your engine!! Now that will be very very bad indeed!!

  9. #9
    mattydipps's Avatar
    Join Date
    Mar 2013
    Location
    Babylon, Long Island
    Posts
    652
    +1
    51
    Okay I found a puddle of antifreeze in the bottom of the hull.. It was dark last night so I'm not sure what I was looking at... Also found this on the bottom of the hull.. What is it ??

  10. #10
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    is your opas removed? i think its one of the linkage hoses....

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question about winterizing when pumping RV antifreeze.
    By ashnic in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 09-19-2014, 05:05 AM
  2. Winterizing antifreeze question...
    By dwbarg in forum Kawasaki PWC Performance (4-stroke)
    Replies: 17
    Last Post: 11-17-2013, 04:13 PM
  3. Replies: 8
    Last Post: 11-12-2013, 10:02 PM
  4. Antifreeze winterizing question
    By qr3379 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-29-2012, 01:49 PM
  5. Replies: 4
    Last Post: 10-10-2007, 02:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •