Results 1 to 1 of 1
  1. #1

    2008 Challenger 230 Issue-Please help

    I recently bought an 08 Challenger 230 with twin 215's. Problem is the engines run out of sync. The starboard engine runs at about 1,000 rpm's higher than the starboard, and the spread gets wider at higher rpm. Had the boat to the local seadoo dealer at deep creek lake in MD and they told me all was good. It lacks performance and will only get to about 45 mph. The port engine will not seem to get to max rpm. Any ideas on this would be great. The boat has under 30 total hours on it.

    Also, interested in possible performance upgrades or suggestions. This is my third sea doo and still also have a 2006 Speedster 200 with twin 215's and love it.

    Thanks, Kirk
    Last edited by 1choiceautosales; 04-27-2014 at 10:24 AM. Reason: correction

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine Issues Please HELP!!!!!!!!!!
    By hemiboy29 in forum 4-Tec Performance
    Replies: 26
    Last Post: 10-15-2009, 04:58 PM
  2. 1200R Engine/Bog Issue, PLEASE HELP
    By GP1300Racer in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-14-2009, 08:07 PM
  3. 2002 Kaw 1100 Stx d.i. issues-- please help!
    By sundedriver in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-03-2009, 10:59 AM
  4. 96' SPX start issues. Please help!
    By goBENGALS in forum 2-Stroke Performance
    Replies: 1
    Last Post: 11-02-2008, 08:01 AM
  5. powervalve issue. please help!
    By jeremy3477 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-21-2008, 07:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts