Results 1 to 5 of 5
  1. #1

    Join Date
    Jul 2010
    Location
    Ireland
    Posts
    37

    Seadoo GTX-s/c- help needed. oil light problem????

    Hi

    I have a 2004 seadoo gtx supercharged. The oil light waring was going off and also i had collapsed oil filter problems due to water getting into the oil system.

    This week i replaced the oil pressure regulator (torqued to 10Nm) , rotary seal at rear of water pump and adjacent oil seal at oil pump. Also replaced the exhaust manifold as it was very badly corodded and leaking water. Checked screen in PTO casing and it was clean. (didnt check scavenge pump screen)

    Thinking i had all bases covered and the problem solved i brought the ski out on the water today only to find the oil warning is still present. The previous owner says he just had the rear oil pressure sensor replaced THREE times. Front sensor hasnt been replaced. It goes into limp mode at 3000rpm.

    I will test oil pressure again tomorrow but could it be another faulty OPS??? Could i be that unlucky??

    Any other ideas greatly appreciated. Patience running out with this !!

    Thanks


  2. #2

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    779
    +1
    39
    I would put an oil pressure gauge on it just to see what kind of pressure it has. There is a port on the back of the head to ck. Gauges are like 20 bucks.

  3. #3
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    Did you try idling around and warming it up first? Normally that helps. Mine did the same and after it was warmed up it ran fine

  4. #4

    Join Date
    Jul 2010
    Location
    Ireland
    Posts
    37
    Ya idled around for 10 mins exactly. Will put a pressure gauge on it today.

  5. #5

    Join Date
    Jul 2010
    Location
    Ireland
    Posts
    37
    Just an update. The ski will still give off the OIL warning when the two OPS plugs are removed.
    I thought the OPS was normally closed and when pressure rises the sensor earths the single wire to complete the circuit to the alarm.
    How is it possible to have an alarm when the two sensors are disconnected.??
    Faulty wiring loom? Faulty ECM?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 seadoo gtx issue, please help me!
    By blee in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-29-2017, 09:42 PM
  2. Knackered Jet Pump Housing On Seadoo GTX 2001. Please Help!
    By imtuttle in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-29-2017, 10:45 AM
  3. 97 seadoo gtx hits rev limiter.. need help!
    By spenserhorton in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-26-2011, 12:12 PM
  4. Two 1994 Seadoo GTX's Please Help
    By katz1002 in forum 2-Stroke Performance
    Replies: 11
    Last Post: 06-08-2010, 12:57 PM
  5. NEED HELP! with oil pressure problem!...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 55
    Last Post: 11-21-2006, 05:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •