Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    2013 RXP-X suddenly died while cruizing

    Hello,

    Last march i bought a left over rxp x260 from a original seadoo dealer ( registred powercenter) with warranty. In 4/5 weeks i put 16 hours on the clock, and at 10 hour i had it serviced like it should. Last weekend i was cruizing for like an hour of 2, suddenly i heard a noise. The noise was like a humming sound. I stopped the ski and looked underneith it, that noise was the same like if you sucked something up.. But the whole intake grate and impellor was clean. After 15 minutes i had to start because a large ship was coming down the river i ran it for 5 minutes but the noise was buzzing and suddenly the noise wasn't there. but then i heard a sort of nock and the whole engine died, pulled up the seat and smelled a burning smell in it and a little smoke ( think blue but don't know for sure).. After this i had it towed to the drop site for about 12km ( towed max. 12kmph).

    I called my dealer up and i have to bring it to them.. She now is at the shop but they haven't had the time to work on it yet. The mechanic says that the motor when it starts looks like is spinning every time more dificult, like its going to lock.. Next monday/tuesday its on the agenda for inspection etc.


    Oil is OK, Coolant is OK. No water in PWC, completely dry. Battery full. I did not do any stunts or so, was just cruzing at 50-60 kmp ( 30-35mph) that day.

    Just out curiousity what do you guys think what happened, or what the problem is.

    This is my 7th ski and bought a new one just because the trouble i had with 2nd hand ski's in the past. Thought buying a new ski would mean cruizing without problems, but unfortunatly it isn't.



    Greetings Joey
    Last edited by joeyholland; 05-02-2014 at 08:17 AM.


  2. #2
    No ideea,keep us informed.

  3. #3
    Quote Originally Posted by dr.seadoo View Post
    No ideea,keep us informed.
    Will inform! maybe interesting for u guys.

  4. #4
    MPG350's Avatar
    Join Date
    Apr 2014
    Location
    Trinity, FL
    Posts
    131
    +1
    7
    Sort of sounds like an issue I had before...I bought a used ski and the ski started to make a weird noise sort of like a buzz but not loud then bam the ski stopped running. I thought for sure motor was blown because the motor was not turning over at all on a good battery. Turns out the prior owner didn't do any service on jet pump and it seized on my first ride....

    A new ski shouldn't have a jet pump seize but maybe wasn't put together correctly.

    Goodluck, nice to have a warranty.

  5. #5
    Derek45's Avatar
    Join Date
    Feb 2014
    Location
    MO. Mark Twain, LOTO
    Posts
    461
    +1
    26
    yep maybe jet pump bearings, alittle strange they would go south in such little time

  6. #6
    Jet pump is what the dealer mentioned of what it could be

    @ mpg350 exactly the same.. @derek, really strange yes

    Should expect to be good.

  7. #7
    MPG350's Avatar
    Join Date
    Apr 2014
    Location
    Trinity, FL
    Posts
    131
    +1
    7
    Quote Originally Posted by joeyholland View Post
    Jet pump is what the dealer mentioned of what it could be

    @ mpg350 exactly the same.. @derek, really strange yes

    Should expect to be good.

    I am far from a sea doo mechanic but I am confident your jet pump is your problem.
    If so your engine should be fine and shouldn't take to long to get back on the water.

    Really strange that would go bad so quick...maybe a bad gasket.

  8. #8
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Possible supercharger failure. How many hours on it?

  9. +1 by:


  10. #9
    16 hours now..

  11. #10
    Quote Originally Posted by dpracing View Post
    Possible supercharger failure. How many hours on it?
    Btw, somebody once told me superchargerfailure is not covered in warranty.. a shop holder ( not a powercenter) said he bought a newe charger and failed again after 15 hours, even then he ain't got it covered..

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 Rxp Riva Stage 3 died while cruising
    By synergy141 in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-16-2015, 08:59 PM
  2. FS - Parts 2007/2013 RXP & RXPX Parts...THREAD OF THE YEAR!
    By REID2168 in forum Sea Doo Classifieds
    Replies: 376
    Last Post: 07-26-2013, 11:41 AM
  3. RXP 06 died while running now it wont start
    By Kl0n in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-16-2010, 03:54 PM
  4. 96 XP Died while cruising, now no spark!
    By 1996XP in forum 2-Stroke Performance
    Replies: 28
    Last Post: 07-12-2008, 06:35 AM
  5. Just dies while cruising
    By mea43 in forum Yamaha Old School Skis
    Replies: 10
    Last Post: 05-23-2007, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •