Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33

Thread: Blown SC seal

  1. #1
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,351
    +1
    105

    Blown SC seal

    Had about an hour on on a rebuilt SC with a ET137 +3 wheel. I noticed a loss of RPMs and boost and oil light was going on and off. Ended up pulling the intake off the SC and found a lot of oil. This was a viton double lip seal. Looks to me like it overheated. Anyone seen this with the viton seals? Pics are not that good but you can see that the seal split in several places. Also my AFR quit working, could this be due to the extra oil that was being sucked blown thru the motor?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	SC seal.jpg 
Views:	99 
Size:	57.9 KB 
ID:	328236   Click image for larger version. 

Name:	SC seal1.jpg 
Views:	117 
Size:	71.0 KB 
ID:	328237  


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Haven't seen this on any of the vitons yet....this is a first...you stated you were losing boost and RPM s....you might want to check out the rest of the charger for a issue or bearing starting to fail...

  3. #3
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,351
    +1
    105
    Just rebuilt the SC, less than an hour on it. Boost went from 14 to 13, rpms 8400 -8200. I'm assuming the boost was down because the rpms were down and the rpms were down due to the super rich fuel/oil situation.

  4. #4
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    I had 2 different viton seals fail on a 45hr charger 137+3... they fell apart it looked like... I rebuilt the charger and put a OEM seal in and it's been good ever since.. ( i believe new oem seals are viton also)
    http://i1175.photobucket.com/albums/...ps34511e43.jpg
    http://i1175.photobucket.com/albums/...psfd97a906.jpg

  5. #5
    what type of engine oil when happend!?

  6. #6
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,351
    +1
    105
    Looks like mine but a lot worse.

    Quote Originally Posted by Sturm215 View Post
    I had 2 different viton seals fail on a 45hr charger 137+3... they fell apart it looked like... I rebuilt the charger and put a OEM seal in and it's been good ever since.. ( i believe new oem seals are viton also)
    http://i1175.photobucket.com/albums/...ps34511e43.jpg
    http://i1175.photobucket.com/albums/...psfd97a906.jpg

  7. #7
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    Throw on a brand new OEM out of the newest kit and be done with it.

  8. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Sturm215 View Post
    I ( i believe new oem seals are viton also)
    Correct,they are a single lip style were the ones we are running are double...

  9. #9
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,351
    +1
    105
    Yes the ones in the new kits are Viton but are not the double lip design. I installed one from a new kit, we'll see how it works out.

  10. +1 by:


  11. #10
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    What SC oil supply setups are the blown ones in?
    X oil supply to shaft?
    OEM bearings?
    X SC oil relief hole?
    what oil you running?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blown SC! Any Help???
    By Hector_750 in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-07-2008, 01:27 PM
  2. Blown SC after 32 Hrs, then Blown motor!
    By Chris0060 in forum 4-Tec Performance
    Replies: 11
    Last Post: 09-10-2007, 01:11 PM
  3. blown front seal
    By LETHAL RX7 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 07-29-2007, 10:33 AM
  4. Blown SC 11hrs!
    By scplgp in forum 4-Tec Performance
    Replies: 47
    Last Post: 06-29-2007, 05:57 PM
  5. 2nd blown SC..bov
    By mxl16 in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-31-2005, 06:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •