Results 1 to 9 of 9
  1. #1
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117

    are clutch washers suppose to be rough/pitted?

    lost some slip on my charger so I pulled it and noticed the clutches are really pitted. is this normal?

    charger was rebuilt by Jerry about 30hrs ago.

    thanks for any help.
    Click image for larger version. 

Name:	IMG_1812[1].jpg 
Views:	139 
Size:	107.6 KB 
ID:	328497Click image for larger version. 

Name:	IMG_1816[1].jpg 
Views:	145 
Size:	115.8 KB 
ID:	328496


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    yes

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Even though those are the OEM metal ones,I dont like the way they look,Especially picture number 2..I would replace them...BUT Thats just me,

  4. #4
    replace.....you have a lot of slip efect there,check the clucth too.

  5. #5
    Ermiller27's Avatar
    Join Date
    Mar 2009
    Location
    Cleveland OH, Geneva NY
    Posts
    47
    +1
    1
    Check your oil too and see if there is any metal bits floating in it

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Ermiller27 View Post
    Check your oil too and see if there is any metal bits floating in it

  7. #7
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    New riva's ordered along with needle bearings. Thanks guys.

  8. #8
    check the shaft and the plate where the washers rub on for wear

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by winterstick View Post
    check the shaft and the plate where the washers rub on for wear
    along with the gear too

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Are these hose suppose to be like this?
    By xewkija631 in forum 4-Tec Performance
    Replies: 9
    Last Post: 04-26-2015, 01:21 PM
  2. Replies: 7
    Last Post: 11-19-2013, 11:14 AM
  3. What size Gap of the plug is this 780 supposed to be?
    By JGringo in forum Polaris PWC Performance
    Replies: 16
    Last Post: 08-22-2007, 11:27 PM
  4. Are these aftermarket carbs supposed to be routed this way?
    By JGringo in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-16-2007, 04:10 PM
  5. When are the skegs going to be available?
    By Chezzy in forum 4-Tec Performance
    Replies: 22
    Last Post: 05-16-2006, 09:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •