Results 1 to 5 of 5
  1. #1

    Join Date
    Sep 2011
    Location
    Annapolis MD
    Posts
    199
    +1
    8

    Damaged '04 IAT Sensor!

    So I have owned my '04 msx for probably 3 years now, and ever since I have always had some issues with rich(oily) fouled plugs... So I decided to check out the IAT sensor since it affects how rich or lean the (one factor anyway) the EMM makes the fuel / air mixture.

    Here is what I found:

    This was pulled from the engine.

    Click image for larger version. 

Name:	District 4 Kent Island-20140503-00944.jpg 
Views:	41 
Size:	61.4 KB 
ID:	328551

    It looks like it was jabbed with a screw driver or something!.... And no I didn't do that when I removed it lol.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Check the reinforcing ribs under the flame arrestor cover. It is common for the rib closest to the air temp sensor to cut into the sensor. I trimmed back the plastic rib so it cannot damage the sensor on my own.

    Polaris also made a revised spacer kit that lowers the sensor a few mm.

    Does your sensor fail the ohms measurement test?

  3. #3

    Join Date
    Sep 2011
    Location
    Annapolis MD
    Posts
    199
    +1
    8
    Quote Originally Posted by K447 View Post
    Check the reinforcing ribs under the flame arrestor cover. It is common for the rib closest to the air temp sensor to cut into the sensor. I trimmed back the plastic rib so it cannot damage the sensor on my own.

    Polaris also made a revised spacer kit that lowers the sensor a few mm.

    Does your sensor fail the ohms measurement test?
    I didn't measure the resistance, but I went ahead and installed a new one with the spacer kit. The flame arrestor didn't appear to be interefering with it when I removed the cover. What is the proper resistance value for the sensor at room temperature?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by Makon View Post
    Quote Originally Posted by K447 View Post
    Check the reinforcing ribs under the flame arrestor cover. It is common for the rib closest to the air temp sensor to cut into the sensor. I trimmed back the plastic rib so it cannot damage the sensor on my own.

    Polaris also made a revised spacer kit that lowers the air temp sensor a few mm.

    Does your sensor fail the ohms measurement test?
    I didn't measure the resistance, but I went ahead and installed a new one with the spacer kit. The flame arrestor didn't appear to be interefering with it when I removed the cover.

    What is the proper resistance value for the sensor at room temperature?
    According to a 2001 Ficht manual I have handy, the Ficht Air Temperature sensor at 77F should measure between 990 ohms and 1010 ohms.

    The Ficht exhaust temp sensor at 77F should measure between 985 ohms and 1015 ohms.

    Both sensors have positive temperature coefficients. As temperature increases the resistance also increases.

  5. #5

    Join Date
    Sep 2011
    Location
    Annapolis MD
    Posts
    199
    +1
    8
    Shit, well it turns out I pitched the old sensor when I replaced it... Oh well, when I launch the ski this weekend i will find out if it made any difference. I also had tightened up the throttle cable a bit since it seemed that there was a little slack (I could slightly pull the throttle trigger and the throttle blades would stay closed).

    Isnt there some kind of adjustment to the TPS that can be made to verify that it is correctly sensing the throttle position to the EMM?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need a 04 knock sensor update
    By rapidacceleration in forum 4-Tec Performance
    Replies: 44
    Last Post: 04-04-2010, 06:57 PM
  2. CODE 9 IAT sensor
    By mac1224 in forum Honda How To & FAQs
    Replies: 2
    Last Post: 07-23-2008, 06:55 PM
  3. 04 knock sensor update.
    By 98Hawk in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 04-26-2007, 12:11 AM
  4. Help understanding the 04 knock sensor update.
    By Summitt in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 01-16-2007, 10:07 PM
  5. 04 rxp 'sensor' /high idle/trim gauge
    By cdooRXPxtrm in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-17-2006, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •