Results 1 to 2 of 2

Thread: High 12v?

  1. #1
    Sammynels's Avatar
    Join Date
    Jul 2013
    Swansea, MA.

    High 12v?

    Took my ski out for the first time this year. Keep getting a POS63 error "Hi 12V". Anyone know anything about this. If I can recall, it was doing this here and there last year at the end of the season. I just replaced the battery, didn't fix it of course. Let me know what u guys think. Thx.
    2007 SEADOO RXT215 no mods

    swansea, MA

  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Tampa Bay, FL
    A failed rectifier will cause that alarm, and is most likely your problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 RXP 12V High reading on Panel
    By trevtrev in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-11-2013, 06:05 PM
  2. 12V High error?
    By Ryallen in forum 4-Tec Performance
    Replies: 16
    Last Post: 04-15-2013, 12:34 PM
  3. 12v High Message
    By Piney in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-30-2011, 06:43 PM
  4. Replies: 12
    Last Post: 09-10-2010, 06:36 PM
  5. Can high heat and humidity take away 200 rpms?
    By Vern in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-08-2005, 12:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts