Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53

    08+ fuel set up on older skis

    Has anyone modded an older fuel pump assembly to take the newer 08+ screw type set ups ?


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    You would have to change the tank, and the fuel pump module to make it work. The harness connector is different also (i think), and u would have to change the connector, or the Main Wire harnesses to 08+ (which use a different voltage Regulator, &
    connector as well as fuse box assy).

    I'll be adding all 08+ electronics, and parts to an 05, or 06' RXT with VTS soon.

  3. #3
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    why would you want to is my question. Just drop in a walboro or aeromotive

  4. #4
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    Because I'm building a ski and have 08 harness, gauge and ecu. Fuel pump will be aeromotive but that's got nothing to do with it.

  5. #5
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    Quote Originally Posted by psycho rxp View Post
    You would have to change the tank, and the fuel pump module to make it work. The harness connector is different also (i think), and u would have to change the connector, or the Main Wire harnesses to 08+ (which use a different voltage Regulator, &
    connector as well as fuse box assy).

    I'll be adding all 08+ electronics, and parts to an 05, or 06' RXT with VTS soon.
    Do u know what's different with the voltage regulators ? be easier to wire up the 06 fuel pump with the 08 harness if the voltage etc is the same ?

  6. #6
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    I know the plugs are different on the voltage reg and the fuel pump .I have 05 harness I could butcher for you for the plugs if you need. I have a 05 reg too .

  7. #7
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    thanks mate but I'm more looking at if I can wire up the old connectors to the 08 harness if the voltage is still the same, just looking at what regulator to use. I have an 05,06 and 08 harness but am using all 08 electronics on an 06 engine. I'll have a look at the schematics of both.

  8. #8
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    on mine I have 08 electrics on an 08 engine but an 05 pump so I changed the plug to suit the pump same colour wires different plug. what reg do you have ?

  9. #9
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    I have several year regs but going by what your running an 08 reg will suit and I'll wire up the 06 pump. thanks mate !

  10. +1 by:


  11. #10
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    I didnt do this but when you cut the loom to change plug put a relay in. Thats if you were going to run one

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone have the NEW RIva Steering set up on the newer skis?
    By Water4fire in forum 4-Tec Performance
    Replies: 3
    Last Post: 12-04-2012, 04:38 AM
  2. Riva Rear air set up on 08 set ups ????
    By mrbtd in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-19-2010, 06:44 PM
  3. SX-R 800 Set up on the MIKUNI 46
    By theone1 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 02-22-2008, 03:52 PM
  4. Correct PV set up on 1200R
    By AndyW in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 10-03-2007, 02:58 AM
  5. whats a good efi set up for my ski ?
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 03-14-2006, 09:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •