Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    515
    +1
    47

    Riva Rear Exaust Install Question

    Bout to finish up my Install of the Riva Rear Exit Exhaust.

    Question is...

    Is it alright if i fill the hull up with water to make sure that nothing leaks after im all done?

    I know silly question right!


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    MEH....thats a tough call...

    Quick way is to tip the ski's nose up HIGH and run the hose until submerged, wait 5 minutes....no leak, pull the plugs...

    Did you use any sealant around the outlet? If so you should wait 12-24 hours for it to set up decent...

  3. #3
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    515
    +1
    47
    Yea i uses a silicone sealant around everything, just to make sure! Im gonna give it a few days before i test anything

  4. #4
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    If it was a tight fit, and bolts lined up and snugged good....and silicone got squished out enough to SEE it seal...then you are good to go

  5. #5
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    515
    +1
    47
    I also used some silicone sealant on the stock exhaust outlet plug.

  6. #6
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    515
    +1
    47
    Yea i squeezed a lot of silicone out!

    I just wanted to make sure that its ok to put some water in the hull, raise front and check for leaks after all is said and done?

  7. #7
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    What waterbox are you running? Riva? Gutted OEM?

    OH, and the mods don't mean anything unless you post pictures

  8. #8
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    515
    +1
    47
    Quote Originally Posted by Danny View Post
    What waterbox are you running? Riva? Gutted OEM?

    OH, and the mods don't mean anything unless you post pictures
    OEM...

    Pictures to come! I have them all on my phone!

  9. #9
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    I suggest gutting the box, will make your ski BARK more....and gain some power.

    What other mods?
    Where in Michigan are you?

  10. #10
    05rxp05's Avatar
    Join Date
    Mar 2014
    Location
    Michigan
    Posts
    515
    +1
    47
    Quote Originally Posted by Danny View Post
    I suggest gutting the box, will make your ski BARK more....and gain some power.

    What other mods?
    Where in Michigan are you?
    14/19, Intake Grate and exhaust is all i have right now. Thinking im gonna do a DIY Intake though.

    Gutting the water box, how would one go about doing this?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva Rear Exaust Install Question
    By 05rxp05 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-09-2014, 10:41 AM
  2. Riva Rear intake install
    By Alex13 in forum Sea Doo How To & FAQs
    Replies: 13
    Last Post: 01-19-2013, 07:46 AM
  3. Riva through hull install question
    By mstennes in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-11-2007, 10:02 PM
  4. need help with riva rear exaust guys
    By bob1988 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-17-2007, 10:17 PM
  5. Riva stage II install question
    By RXPNJ in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-18-2006, 09:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •