Results 1 to 9 of 9

Thread: stator test?

  1. #1

    stator test?

    Hello I'm new here and to jet skies. I just bought a used polaris slt 750. When I checked out the ski it had a low battery. He jumped it and it started up just fine. I picked it up the following week end. Got it home and was checking things out. I noticed that some of the screws were out of the cdi and there was a yellow wire sticking out of the side of it. So i opened it up. It was a jumper for the hot neg wire. I then saw where the wire had melted at the top of the rubber cap on top of the cdi box. Long story short I worked my way back to the stator.... and it was burnt all the way to the coil. Melted the protective covering in 6 places. Checked the comp on the cylinders and no. 3 was low...90. So i decided to just pull the motor and see how bad I things were. Its amazing how when you look at something that you really want and you go blind... . I didn't see any of this when i looked at it. It Had a crack in the fiberglass under my left foot....it was under the pad...Fiber glassed it ...got it fixed. Anyway what I need i someone to tell me if my stator numbers are good or if I need to find one. (R/P to Y I got 1.1 ohms should be .6) (R/W TO G/R GOT 490 SHOULD BE 494) (B/R TO R/W GOT 90 SHOULD BE 87.7) (W AND Y TO B GOT 280 SHOULD BE 220) so is this good or bad? Any help here will sure help. I ordered a used cylinder and piston that should be here in a few days. I'm going to pull out the oil pump and mix the oil with the gas. I just worry about the pump stopping and burning up the motor that I just got running. I figure that it worked good for my old dirt bikes so it should be fine for this. Been a lot of years since i had done any motor work. These jet skis can be a real pain in the head to work on. Interesting how they are set up. I figure by the time I get all the parts to fix this up I could have bought a really nice one..... But it is fun (at this point and time) to try to figure out how to fix it. At least i will know what I have when I get done. Please help . Thanks


  2. #2
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Welcome to Green Hulk!

    Don't feel bad... my first ski... a '94 Polaris SLT 750... came with many problems like yours that I too missed on inspection.

    The burnt wire from the magneto stator to the electrical box (CDI is inside the ebox) is a ground wire that all to commonly gets fried if someone sits the metal ebox on top the battery (where it normally sits) WITHOUT the plastic battery cover to prevent arcing the metal ebox to the positive battery terminal. It shorts the ebox which has a direct path to ground through the black wire to the magneto stator. Mine came with way as well... found it after purchase too.

    If the damage doesn't go all the way to the magneto stator... you might be able to salvage it by rewiring any damaged wires... but not a guarantee. See this thread for testing #s on the blue Fuji engine magneto stators

    http://www.greenhulk.net/forums/showthread.php?t=98103

    Also... definitely read up on the Polaris Knowledge bank... for the Fuji (blue engine). You'll see a link to discussions about frying the mag stator wire there also.

    http://polarispwcknowledge.shorturl.com/polaris-fuji-engine

    Well... at least with a full rebuild... you'll know your ski is good to go... and done right... when your finished.

    Cheers!
    Last edited by K447; 05-10-2014 at 08:28 AM.

  3. #3
    Thanks for the welcome and thanks for the info. And getting it done right....time will tell...ive been out of the motor repair for a long time. Thanks for the info..

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Welcome

    See my signature links for good info.

  5. #5
    I do all my readings for ohms set at 300mv ohms is this right? Me and electrical issues are not friends ... : )

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Quote Originally Posted by jetski fisherman View Post
    I do all my readings for ohms set at 300mv ohms is this right? Me and electrical issues are not friends ... : )
    Um, not sure what you are asking.

    What dial setting you use depends on what test you are doing, and how your meter works.

    I have posted some how to test notes in various threads. Not sure if I have aggregated them into a handy list anywhere

  7. #7
    I ordered up a used stator. let you know when I get it all back together. Thanks for all the info so far. Im sure I will need a lot more help.

  8. #8
    got the cylinder and piston in today. started putting in the stator and came up with one problem. The stator has 3 screws that hold it in. the holes that the screws go through are slotted. Im guessing it for advancing the timing and retarding the timing? I cant seem to read anywhere where you should adjust the stator. My manual just tells me to screw it down. So do I just screw it down and not worry about it or am I to adjust it right or left? I'm stuck and I'm not sure what to do. If you can put some light on this please let me know....thanks.

  9. #9
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    See these threads for good info, an attached page from service manual detailing how to align the stator and a picture.

    http://www.greenhulk.net/forums/show...ator+alignment

    http://www.greenhulk.net/forums/show...ator+alignment

    Cheers!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. stator testing
    By seaobin in forum Polaris Open Discussion
    Replies: 18
    Last Post: 07-01-2008, 10:54 PM
  2. gp 1200 stator test
    By chritopherlloyd in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 05-04-2008, 06:16 PM
  3. 785 Stator test question
    By absentx in forum Polaris Open Discussion
    Replies: 4
    Last Post: 02-22-2007, 06:07 PM
  4. 01 slx stator testing
    By 785 lugs in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 09-25-2006, 11:19 PM
  5. fuji stator testing
    By ugadawg131 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 09-25-2006, 05:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •