Results 1 to 3 of 3
  1. #1

    Join Date
    Jul 2011
    Location
    Eastern Washington USA
    Posts
    6

    Smile Starter/ relay issues

    Hello All!
    I was just given a 1990 587 SP. I know it runs as I saw it running last week. When you push the start button there is a loud click in the electrical box over the battery (the starter relay) but nothing happens. What is the most likely problem? the relay or the starter? And if its a toss up what is the best way to tell?
    Any help would be great! Thanks.


  2. #2
    Primary Language: Sarcasm Pony Racer's Avatar
    Join Date
    Jun 2011
    Location
    RiverShit, Ct
    Posts
    480
    +1
    28
    check your battery..

  3. #3
    You can jump your solenoid points real quickly to test and see if it tries to crank.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 06-04-2014, 01:58 PM
  2. 2011 Gti Se electrical issue with starter relay.
    By porschemaniac in forum Sea Doo How To & FAQs
    Replies: 3
    Last Post: 05-29-2014, 01:52 PM
  3. 1992 Kawasaki 750sx...relay?...starter?...bendix?...issue
    By mevansant in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 07-11-2012, 09:33 PM
  4. 2001 XLT1200 starter relay issue
    By skidude in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 05-02-2012, 07:17 AM
  5. Wierd Starter relay problem....NEED HELP???
    By jitees in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-20-2010, 06:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •