Results 1 to 6 of 6

Thread: CDI Confusion

  1. #1

    Join Date
    Mar 2012
    Location
    El Dorado, AR
    Posts
    134

    CDI Confusion

    I have two cdi's here. One is supposed to be a brand new 93 sl650. The other I'm not sure about. I've been trying to fix electrical issues and have replaced various parts. All were supposed to be 93 model but could've easily been falsely advertised. With the two CDIs there is one difference, the black and yellow wire. On the one I had (I think it might be a 94) it has connector for the other half of the electrical box. The brand new one I just got has a bullet connector like the rest of the cdi wires, but there's not a wire for it to go to. So my questions are this...which cdi is actually for a 1993 sl650? Also, if the new one is in fact for a 93, where do I connect that wire? I have a new stator in there but it might be the wrong year. I also have a new electrical box which could also be the wrong year. Idk if it is different between like 93 and 94. I still have the ends to my old stator and I don't see any wire that would connect to that one wire. I'm just really confused. But it could be as simple as I got lied to lol, stupid eBay! I've included pictures of the wire ends and also the part#, so maybe someone could tell which is the right one


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    The pictures didn't show up, but the early years didn't have a circuit board, they simply had bullet connectors. The bullets can be replaced with spade connectors to connect to the board, if that is the layout you have.

    One test proved that the 650 / later 750 parts were not compatible, but the result was failure after a period of time, not initial "no fire".

    Get the pics and part numbers up... Not sure which wire you don't know to connect where..?? The black yellow and black with ring terminal on the CDI do not connect to stator wires. They connect to the kill switch and box ground, respectively.

  3. #3

    Join Date
    Mar 2012
    Location
    El Dorado, AR
    Posts
    134
    Click image for larger version. 

Name:	image.jpg 
Views:	40 
Size:	80.3 KB 
ID:	329058Click image for larger version. 

Name:	image.jpg 
Views:	30 
Size:	55.4 KB 
ID:	329059
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	29 
Size:	78.8 KB 
ID:	329057  

  4. #4

    Join Date
    Mar 2012
    Location
    El Dorado, AR
    Posts
    134
    The pictures are rotated, but the one on the right (top) is the supposedly brand new 93

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    According to the manual

    F8T16273 is for the 1993 650

    F8T16274 is for the 1994 650

  6. #6

    Join Date
    Mar 2012
    Location
    El Dorado, AR
    Posts
    134
    That's what I thought. That's the one with the bullet connector, but there's nowhere to connect it...I'm also pretty sure the original connected to the other half of the electrical box like the 94 does. So I'm really confused haha. Of course I inherited this ski and it was bought used so it could've been altered. Would it be damaging to just splice the 94 wire onto the 93 cdi? Idk..what would you guys do? Would it be fine with all 94 electics but a 93 engine? Or do I need to try and find all 93 electrics?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. wiring the cdi for warm restarts. from confused man :(
    By aj1987 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 04-07-2010, 05:26 PM
  2. CONFUSED ON IMPELLER AND INJECTER MODS
    By 4-techscharger in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-21-2006, 02:03 PM
  3. COMPACTIVE DISCHARGE IGNITION OPERATION (CDI)
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 02-15-2006, 10:53 PM
  4. Advent CDI issues
    By RichGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 11-21-2005, 07:16 PM
  5. I'm confused on what to get!?
    By Totallyblown in forum 4-Tec Performance
    Replies: 49
    Last Post: 11-20-2005, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •