Results 1 to 3 of 3
  1. #1

    Join Date
    Sep 2012
    Location
    Massachusetts
    Posts
    38

    1983 kawasaki js550 electrical problem

    jet ski ran great all last weekend and then when i got there Saturday the battery was barely turning the motor over. I charged the battery for a few hours and put it back in the ski. this is where i began to hit some problems. So to backtrack on what has been done to the jet ski recently. Every piece in the electrical box has been replaced, brand new battery, brand new starter, all brand new battery cables and grounds. So after I charged the battery i put it back in the jetski and pressed the start button, the jet ski turned over for about 5 seconds and then i went to push the button again and there is absolutely nothing. No noise from the starter, no clicking in the electrical box, just no noise at all. Made sure all connections were tight, even took apart the start and stop switch on the handle bars and cleaned it out. The jetski will turn over from the two terminals on the front of the electrical box. So my wuestion is... where is my problem? has anyone ever had this problem before?


  2. #2

    Join Date
    Aug 2011
    Location
    Australia Melbourne
    Posts
    839
    +1
    137
    Quote Originally Posted by parryc13 View Post
    jet ski ran great all last weekend and then when i got there Saturday the battery was barely turning the motor over. I charged the battery for a few hours and put it back in the ski. this is where i began to hit some problems. So to backtrack on what has been done to the jet ski recently. Every piece in the electrical box has been replaced, brand new battery, brand new starter, all brand new battery cables and grounds. So after I charged the battery i put it back in the jetski and pressed the start button, the jet ski turned over for about 5 seconds and then i went to push the button again and there is absolutely nothing. No noise from the starter, no clicking in the electrical box, just no noise at all. Made sure all connections were tight, even took apart the start and stop switch on the handle bars and cleaned it out. The jetski will turn over from the two terminals on the front of the electrical box. So my wuestion is... where is my problem? has anyone ever had this problem before?



    Solenoid has primary terminal/wiring from starter switch (low current ) and secondary terminal/wiring to start motor (high current)... Using and volt meter or test light check for power @ the primary terminal

    to http://www.partzilla.com/parts/searc...ASE/parts.html

  3. #3

    Join Date
    Sep 2012
    Location
    Massachusetts
    Posts
    38
    thanks i will try that

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1983 kawasaki js550 burning out starters?
    By parryc13 in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 10-21-2013, 11:35 AM
  2. 1997 kawasaki zxi 900 electrical problems
    By Jetskikid in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 06-07-2011, 05:24 PM
  3. '04 GTX SC electrical problem
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-01-2006, 06:49 PM
  4. Help me solve this electrical problem
    By MPower in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-26-2006, 09:05 PM
  5. Electrical Problems
    By Red Devil in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-31-2005, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •