Results 1 to 6 of 6
  1. #1

    2010 Kawasaki Ultra 260x Will only IDLE- wont rev past idle!!

    I have a 2010 Ultra 260x with 70 hours on it. Out of nowhere it stop revving up past idle. It fires up immediately but will not do anything other than that. I have already tried to change the spark plugs but nothing changed. It immediately cuts the rev if the throttle is applied. It is not flashing any codes. I do have a riva stage 1 racing kit on it, if that matters. Any suggestions would be great. I'm hoping its not the sc since ive avoided hitting the rev limiter at all costs.
    Please help!!!


  2. #2
    I would start by checking the air intake. Make sure the air horn isn't pressed up against the inside of the hull.

  3. #3

    Join Date
    Jul 2011
    Location
    Miami !!!
    Posts
    59
    It's prolly the super charger belt, I also have a 260 with about 90hr and everytime my supercharger belt rips or breaks, it won't rev past idle...

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    hitting the limiter effects nothing on the sc. my guess you have a seized sc or pulley or broken belt.

  5. #5
    Quote Originally Posted by jose305 View Post
    It's prolly the super charger belt, I also have a 260 with about 90hr and everytime my supercharger belt rips or breaks, it won't rev past idle...
    Thanks for the help! The only reason I think its not the super charger is because a few weeks before this happened consistently, it would some times do this but I would just turn off and on and it would be fine. It probably happened 4 times over 2 weeks before becoming a constant issue. If it is the super charger belt, is that all I will need to replace?

  6. #6

    Join Date
    Aug 2011
    Location
    Australia Melbourne
    Posts
    839
    +1
    137
    Quote Originally Posted by mruss View Post
    I have a 2010 Ultra 260x with 70 hours on it. Out of nowhere it stop revving up past idle. It fires up immediately but will not do anything other than that. I have already tried to change the spark plugs but nothing changed. It immediately cuts the rev if the throttle is applied. It is not flashing any codes. I do have a riva stage 1 racing kit on it, if that matters. Any suggestions would be great. I'm hoping its not the sc since ive avoided hitting the rev limiter at all costs.
    Please help!!!

    Wasn't going to be your plugs.

    Further to what's been already mentioned in other posts.... are you capable enough and have test equipment to undertake some basic tests, ie fuel system and ignition system.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2010 Kawasaki Ultra 260x SUPER CLEAN well maintained with trailer
    By BigBoost in forum Kawasaki Classifieds
    Replies: 2
    Last Post: 09-30-2013, 05:40 PM
  2. 2010 Kawasaki Ultra 260X shuts off if rpm goes over 2000. - Please help
    By serge9193 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 20
    Last Post: 06-20-2012, 12:50 PM
  3. FS Kawasaki Ultra 260x Light Weight Race Ski 2010
    By fastkaz in forum Kawasaki Skis
    Replies: 5
    Last Post: 10-23-2011, 06:08 AM
  4. 96 xp will only idle?
    By justmyskin in forum 2-Stroke Performance
    Replies: 8
    Last Post: 10-16-2009, 10:32 AM
  5. i want my kawasaki ultra 260x be 75 mph
    By JsH in forum Kawasaki PWC Performance (4-stroke)
    Replies: 17
    Last Post: 05-11-2009, 11:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •