Results 1 to 6 of 6
  1. #1

    Join Date
    May 2014
    Location
    Monroe Michigan
    Posts
    3

    Starter not turning fast enough?

    Good afternoon all! Today i decided to get my skis ready to throw back in the water but decided to try and fire them up to make sure everything was ok before I put them in the water. Me being an idiot forgot to take the batteries out. I threw the battery charger on one and let it sit for a few while I worked on the other one a bit. I tried starting the 900 and the starter just spun. So I tried the 750 and the same thing happened. They ran fine when I winterized them. Could the batteries just be way too weak to turn the starter fast enough? Ive read some things about the bendix being bad or something. I would prefer not to tear the whole motor apart for troubleshooting lol. Any help or suggestions would be greatly appreciated! Thank you guys! - Justin


  2. #2
    Resko 1's Avatar
    Join Date
    May 2013
    Location
    Waretown, NJ
    Posts
    81
    +1
    7
    Give them some time to charge before tearing it apart. I would say a few hours each depending on what region your in, and how cold it was for your winter.

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,012
    +1
    283
    If the starter spins, but the engine doesn't crank, it's the starter clutch. You might hit the start button a number of times in an effort to break it loose.

  4. #4

    Join Date
    May 2014
    Location
    Monroe Michigan
    Posts
    3
    I tried to bump it a few times but the batteries were really weak. My 900 gave me a few issues last year but i bumped it a couple times and it started cranking. Im afraid ill be purchasing 2 starters. I hope not...Our winter was really cold. Im in Michigan. We had many days of - 20 to -30.

  5. #5
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,012
    +1
    283
    If the starters spin, they're probably fine.

  6. #6

    Join Date
    May 2014
    Location
    Monroe Michigan
    Posts
    3
    Thanks Steve. 1 Battery is junk the other one is on the charger. Hopefully its just the batteries.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seadoo 951 Limited, Short beep, starter not turning over
    By topfli8979 in forum 2-Stroke Performance
    Replies: 9
    Last Post: 06-28-2015, 03:45 PM
  2. STARTER-not enough torque?
    By MatthewZ in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 04-23-2013, 10:17 PM
  3. Replies: 10
    Last Post: 06-29-2011, 08:48 AM
  4. throttle lever not going back fast enough when releasing it
    By jedisurfer in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 07-04-2009, 10:50 AM
  5. 1996 XP New Battery & Starter not turning over?
    By ianarm77 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 06-28-2009, 09:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •