Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38
  1. #1

    Here she is! Im going to need a lot of help!

    Compression test with a crappy battery charger was 130psi on both cylinders! Help me with this, where should I start? A lot has been taken apart, but looks like all the parts are here. Looks<--- Keyword.

    Click image for larger version. 

Name:	photo 1 (6).jpg 
Views:	61 
Size:	72.0 KB 
ID:	329194
    Click image for larger version. 

Name:	photo 2 (6).jpg 
Views:	67 
Size:	102.9 KB 
ID:	329195
    Click image for larger version. 

Name:	photo 3 (4).jpg 
Views:	65 
Size:	103.3 KB 
ID:	329196
    Click image for larger version. 

Name:	photo 4 (2).jpg 
Views:	61 
Size:	100.6 KB 
ID:	329197


  2. #2
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Congrats! Welcome to the world of Webers!

    So what do you know about it? Any history? When it last ran? What happened to it?

    If you have zero history... I'd really think you need to pull the engine and give it a thorough examination. Say the plastic waterpump drive gear is broken... you'll never know without pulling the engine.

    So... from the pics... a lot has been tinkered with. I don't see the turbo-to-IC hose... nor the IC-to-intake hardpipe and joiner hoses. I don't see the coil packs (took off for compression test?). I don't see the resonator nor the BIG looping waterbox to resonator hose. The jet pump must be off... since the driveshaft is slid back. But that's all I can really tell.

    See if you have the System IFB (SIFB)... above battery... attached to wire harness... below main relay. Those are very hard to come by. Check under the hood above the tank... should see throttle cable hook up to black box with wires... the PPU... and another PPU IFB connected to wire harness... front right side of gas tank. Still got the dash display? Did it come to life and show you anything... like # of hours?

    I personally would pull the engine and inspect everything. Then make a list for what you need. Is the turbo shaft spinning freely? Any bad wobble in it (touching compressor housing)? Is the turbo wastegate arm free and pivoting? Open the butterfly in the eThrottle body (ETB) and peak into the intake. Any oily mess in there?

    Since the oil tank is already off... you might never really know if it had water contamination. I'd pressure test the oil tank and intercooler to ensure no leaks.

    So yeah... lots to do. Good luck. Check your PMs.

    Cheers!

  3. #3
    I will pull the engine this weekend and lay out the parts. Just off if the top of my head the parts you listed some are definitely there, just not in the pic. Pump is in, and the turbo shaft spins free and seems good.

  4. #4
    The dash did come on, and I used the handlebar button to turn it over. I did not look for hours. I am not sure what the SIFB is. I will look when I get home.

  5. #5

  6. #6

  7. #7
    Click image for larger version. 

Name:	IMG_2003.jpg 
Views:	37 
Size:	73.4 KB 
ID:	329405
    Click image for larger version. 

Name:	IMG_2004.jpg 
Views:	35 
Size:	68.3 KB 
ID:	329406

    Click image for larger version. 

Name:	IMG_2006.jpg 
Views:	37 
Size:	74.7 KB 
ID:	329408
    Click image for larger version. 

Name:	IMG_2007.jpg 
Views:	34 
Size:	58.2 KB 
ID:	329409
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_2005.jpg 
Views:	37 
Size:	72.8 KB 
ID:	329407  

  8. #8

  9. #9

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Something funky going on with your attachments.

    Some seem OK and some not

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 951 xpl im going to buy needs pistons and rings
    By pulser9 in forum 2-Stroke Performance
    Replies: 14
    Last Post: 05-11-2010, 08:44 PM
  2. FS:2003 Yamaha AR210, Not happy to sell, but here she is.
    By espritonsevas in forum Performance Boats Classifieds
    Replies: 0
    Last Post: 08-10-2008, 09:09 PM
  3. FS:2003 Yamaha AR210, Not happy to sell, but here she is.
    By espritonsevas in forum Yamaha Classifieds
    Replies: 0
    Last Post: 07-16-2008, 09:35 PM
  4. OK, need to know who is gonna go to the Charleston Rally
    By Smitty in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-19-2006, 09:12 AM
  5. Is anyone going to try the new ECU??? I may, My options
    By Jrsrxp in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-05-2005, 09:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •