Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Rxdi won't rev

  1. #1

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308

    Rxdi won't rev

    Okay so I have a 2002 rxdi 951 I have just completely rebuilt the engine new crank and top end as well as the compressor. I finally got everything done and my ski started right up and then did a long beep and says maint so I went to my buddies shop and he hooked up the seadoo diagnostic tool to it and it says tps out of range and I have replaced them and changed harnesses and computers and the mag shows at 4% and the pto at 200% which is wide open throttle I have reset them and it still shows it even unplugged it shows wide open what could this be.


    my buddy seems to think that it's fuel pressure I noticed that the hose that comes of the compressor was hardly blowing any air at all what psi should I be getting from the fuel pump and the compressor


    currently the the ski will start right up and idle all day but when you give it has it bogs in or out of water


  2. #2
    They have to read the same value.

    Check your wiring between the tps and mpem and do a reset.

    It will pay to check that Both throttle bodys are closed.

  3. #3
    You need to readjust both tps sensor ,there is a procedure in the shop manual ,i had 2skis with same problems.,readjust idleing with the tps and it must work

  4. #4

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Okay I have tried resetting the tps I've changed the tps sensors and Iver changes harness and I also changed mpem and it has the same issue it will not rev and it states tps is out of range

  5. #5
    Quote Originally Posted by jetski4ever View Post
    Okay I have tried resetting the tps I've changed the tps sensors and Iver changes harness and I also changed mpem and it has the same issue it will not rev and it states tps is out of range
    by readjust a mean...not reset with B.U.D.S....,if you have a shop manual take a look at tps calibration chapter.

  6. #6

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Were in the shop manual is it I looked and I only found a short paragraph about it.

  7. #7

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Okay i found it in the manual and it states that you need the buds system to do it, how did you guys do it without it because ive already taken it to a shop and they were stumped they hooked it up to the buds system and couldnt do it.

  8. #8
    Quote Originally Posted by jetski4ever View Post
    Okay i found it in the manual and it states that you need the buds system to do it, how did you guys do it without it because ive already taken it to a shop and they were stumped they hooked it up to the buds system and couldnt do it.
    tomorow i'll look and tell you something

  9. #9
    Try this.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	uploadfromtaptalk1401054517538.jpg 
Views:	155 
Size:	48.1 KB 
ID:	330313  

  10. #10
    Click image for larger version. 

Name:	DSC06597.JPG 
Views:	71 
Size:	160.6 KB 
ID:	330360Click image for larger version. 

Name:	DSC06598.JPG 
Views:	69 
Size:	156.8 KB 
ID:	330361Click image for larger version. 

Name:	DSC06599.JPG 
Views:	66 
Size:	152.0 KB 
ID:	330362Click image for larger version. 

Name:	DSC06600.JPG 
Views:	54 
Size:	154.7 KB 
ID:	330363
    take a look at this.

    It's in spanish,i don't have the english version,sorry

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 RXDI won't rev up under load
    By Lk40hp in forum 2-Stroke Performance
    Replies: 12
    Last Post: 07-20-2016, 03:06 PM
  2. WaveRaider won't rev past 3000 RPM ?
    By Jolly Roger in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-20-2008, 02:01 PM
  3. 2001 ultra won't rev
    By burdmark in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 09-11-2007, 04:50 PM
  4. MSX 110 Won't rev up fully
    By bcbill in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-26-2007, 12:04 PM
  5. STX1100 won't rev out
    By wedoseadoo in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 05-09-2007, 09:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •