Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38

    Pressure Behind Oil Fill Cap- Oil Leak

    Finally got to take the boat out yesterday to see if everything was fixed that I worked on during the winter. Other than 1 more water leak that I found all the fixes I did were good HOWEVER the same engine that kept giving me a check engine light- it would go into limp mode till I stopped, unplugged the dess key and restarted it. I hooked it up to the can-doo last year and it showed that the oil sensor or TOPS valve was bad. I replaced both sensors top and bottom and activated the TOPS valve with the dess key and can-doo and I heard it click. I did this a few more times and it seems to be working. FF till last night..............
    I start the boat- 2004 Speedster 200 , twin 155 N/A engines- on the trailer in the water and am looking for leaks and letting the engines warm up. After a few mins I shut them off and I hear a hiss sound. Puzzled I look around and locate the noise coming from the port engine ( the same one that had the sensor issue or so I thought ). The noise stops. I restart it and run for a few mins, stop and I hear it again. This time I locate air and a light oil spatter escaping from the top valve cover- see pic. I unscrew the oil fill cap and it releases a ton of pressure and the hiss stops. WTF . I am at the end of my rope with patience with this dam thing. What can be causing such pressure under the oil cap in such little time ?? HELP
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20140515_191135.jpg 
Views:	72 
Size:	76.6 KB 
ID:	329576   Click image for larger version. 

Name:	20140515_191721.jpg 
Views:	64 
Size:	84.9 KB 
ID:	329577  


  2. #2
    Derek45's Avatar
    Join Date
    Feb 2014
    Location
    MO. Mark Twain, LOTO
    Posts
    461
    +1
    26
    I feel your pain brother as I have yet to get my 04 Rxp on the water, hook to candoo when I hooked mine up for the test there was like a dbl. click then pause then slight click as if closing, there should be a ohm test reading for this in the manual to verify its good.

  3. #3
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Hoping to get to remove the valve today after work. This past weekend was to busy to have time to work on it.

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Do a compression check and leak down test.

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    Can you snap a pic of the valve cover and vent hose connected to the TOPS tower.

  6. #6
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    I can today after work, just a pic of the top view of the cover? I did not have a chance to remove the valve cover yet to replace the gasket although it isn't blown out. Also do you think the TOPS valve can be bypassed or disabled to vent all the time? Its in a boat so it wont be flipped.

  7. #7
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Quote Originally Posted by beerdart View Post
    Can you snap a pic of the valve cover and vent hose connected to the TOPS tower.
    Here ya go
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20140519_194458.jpg 
Views:	41 
Size:	87.2 KB 
ID:	329839   Click image for larger version. 

Name:	20140519_194954.jpg 
Views:	59 
Size:	105.6 KB 
ID:	329840  

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    If your not concerned with roll over then you can run the vent off the valve cover to the intake or catch can.

  9. #9
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Its in a boat, if that flips I think that is the least of my worries. How would you vent it? Run a T fitting from the valve cover hose into another T on the hose that is already going into the intake tube ( see pic ) Or can the plunger disks be removed on the TOPS valve and everything else be left as-is?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	attachment.jpg 
Views:	46 
Size:	93.2 KB 
ID:	329862  

  10. #10
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Anyone

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Friend ran rxpx with missing oil fill cap
    By Lstorm2003 in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-07-2016, 12:21 PM
  2. Oil leak from behind oil pump - 787
    By CZSteve in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-12-2014, 01:17 PM
  3. Severe oil leak...low oil pressure light...300x
    By OCEANSIDE in forum Kawasaki PWC Performance (4-stroke)
    Replies: 70
    Last Post: 06-18-2012, 09:49 AM
  4. check out these billet oil fill caps
    By Green Hulk in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-28-2011, 01:12 PM
  5. Replies: 10
    Last Post: 05-31-2006, 09:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •