Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1

    Join Date
    May 2005
    Location
    St. Louis MO
    Posts
    441

    Trailer receiver and ball issues!

    I can't get my damn receiver to drop on the ball. Its stuck on the top of the ball. Is there any suggestion or ideas on how to fix the issue? I wanna go buy a new receiver but I think the one I have can be fixed!


  2. #2
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    By reciever are you talking about the part of the trailer that sits on the ball? If so then look underneath and you will see a nut. Loosen the nut just enough so the trailer drops onto the ball.

  3. #3

    Join Date
    May 2005
    Location
    St. Louis MO
    Posts
    441
    ok I will try that! thanks

  4. #4
    is the latch in the up position?...PR...

  5. #5
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    I was hoping.

  6. #6
    then why would he have to loosen the nylon lock nut underside of the coupler to get it on? maybe it`s all crapped up!?...PR...

  7. #7

    Join Date
    May 2005
    Location
    St. Louis MO
    Posts
    441
    Yes the latch is up I will try the nut in about 3 hrs when I go back to theh shop! What ya mean by all crapped up?

  8. #8
    corrosion or dry, lack of ball grease would make mechanism stick...PR...

  9. #9
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    My uncles trailer receiver is slightly bent. This requires perfect alignment over the ball or it won't go on. Maybe look into that?

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    spray some bombardier lube up in that sucker and jiggle the shit around, and it'll come..... i mean it'll go... onto the ball... like it's supposed to.

    i'm assuming you didn't get a new ball or new receiver right and this has worked in the past, just stopped working all the sudden? if anythign is new, you sure your ball and receiver are the same size right?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. limp mode and electrial issues
    By 89fsj in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-22-2007, 06:50 AM
  2. Modded waterbox and strap issue.
    By The Bandit in forum 4-Tec Performance
    Replies: 18
    Last Post: 06-23-2007, 05:05 PM
  3. 250X mods and warranty issues
    By Beagleman62 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 17
    Last Post: 03-30-2007, 10:20 AM
  4. PWC TRAILER BOX AND 6-CAN GAS RACK
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 21
    Last Post: 04-21-2006, 09:40 PM
  5. RE ball issue
    By Compwhiz82 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 11-19-2005, 09:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •