Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10

    Cavitating out of the hole

    Ran my new to me 09 rxp yesterday. No complaints really other than the hit 70mph and it just sits there. Runs right up to it and sits there. 8050-8100. Fast enough but still felt like it had more.


    The issue I have is the cavitating out of the hole. Dead stop and she spins pretty good with full throttle. planned out or pushing water, grabs and goes.


    What can be done to remedy this? My SHO did not do this.


    Note: my VST does not work right now and the pump nozzle is slightly above center.


  2. #2
    WickedXP's Avatar
    Join Date
    Aug 2013
    Location
    MASS
    Posts
    366
    +1
    50
    Quote Originally Posted by shore View Post
    Ran my new to me 09 rxp yesterday. No complaints really other than the hit 70mph and it just sits there. Runs right up to it and sits there. 8050-8100. Fast enough but still felt like it had more.


    The issue I have is the cavitating out of the hole. Dead stop and she spins pretty good with full throttle. planned out or pushing water, grabs and goes.


    What can be done to remedy this? My SHO did not do this.


    Note: my VST does not work right now and the pump nozzle is slightly above center.
    Might be a bad wear ring

  3. #3
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    Quote Originally Posted by shore View Post
    Ran my new to me 09 rxp yesterday. No complaints really other than the hit 70mph and it just sits there. Runs right up to it and sits there. 8050-8100. Fast enough but still felt like it had more.


    The issue I have is the cavitating out of the hole. Dead stop and she spins pretty good with full throttle. planned out or pushing water, grabs and goes.


    What can be done to remedy this? My SHO did not do this.


    Note: my VST does not work right now and the pump nozzle is slightly above center.
    The nozzle will affect the holeshot slighty but mainly if you have a good wear ring and prop and shes pulling hard the nose will rise.
    Id check the wear ring and prop I got a rxp in a px and rode her and it was terrible out the hole and top end wasn't great either new ring and filed prop as previous owner had obv sucked something up and it was a different ski.

  4. #4

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10
    Maybe I'm making more of this than it is. It does rise but it certainly slips. if I back off and hit it again, it grabs. Not sure how long wear rings last but this was a freshwater 60hr ski.

  5. #5
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    Quote Originally Posted by shore View Post
    Maybe I'm making more of this than it is. It does rise but it certainly slips. if I back off and hit it again, it grabs. Not sure how long wear rings last but this was a freshwater 60hr ski.
    Just like a car clutch slipping??A wear ring life span is dependant on where you ride and if you've sucked any crap up ie in shallow water sub 2ft is bad for stock wear ring due to sucking material in shallow water sand etc.
    At 60hrs its probably knackered although theres people on here who have put over 100hrs on them but I personally change oe rings every 20-40 hrs but killed a stock ring in less than 1 hour one day in the sea.

  6. #6
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    Ps does the ski bounce all over the limiter out the gate?

  7. #7

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10
    Quote Originally Posted by baba850r View Post
    Ps does the ski bounce all over the limiter out the gate?
    not sure. If ridden normal it doesn't really do it, if 3/4 throttle or better, it skips/cavit a bit.

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Fix the VTS. Trim all the way down, get over bars, trim up as you come out of the hole. Check your prop and wear ring.

    A RXP doesn't and will not holeshot like a RXPX.

    Add: the speedo will not go over 70 on stock ECU. You could be going 75mph and it will still read 70.

    Get a GPS.

  9. #9

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10
    yup, waiting on that Trimfix thingy that guy sells. he says it'll fix it so we'll see.

    I was thinking the issue was either the carbon seal or the wear ring.

  10. #10

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10
    Pulled the pump and the wear ring was certainly worn, the leading edges of the impeller has a good bit good bit of dings but not bad IMO. I did the freezer method and the ring and came right out and installed the new one. I did get the aftermarket orange one. I was a little concerned about the orange one but it was too late when I realized it wasn't OEM. Everything went back together good and took it for a ride all day yesterday.

    same thing, if not a little worse out of the hole. From a dead stop nailing the throttle with trim up or down will result in a couple rev limiter taps. Half throttle and then full, it pulls hard.

    Mid-range and top-end and stronger now. I ran side by side with my buddies 260px in mid and top.

    I watched vids of new wear ring installs and noticed in more than a few that the ring would actually be tight enough to make some contact with the impeller when spun by hand. This orange one certainly did not make any contact. It didn't look much tighter than the one that was in it, except for the large grooves worn in the stock one.

    Am I going to have to do another wear ring, OEM this time? Will that little bit of clearance make it spin only out of the hole?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 250x cavitating out of the hole
    By cvbdrew in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 07-01-2013, 05:21 PM
  2. 2008 RXP CAVITATION out of the hole and hitting rev limiter
    By eschanen85 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-18-2013, 01:00 PM
  3. Need help cavitation out of the hole
    By andre in forum 4-Tec Performance
    Replies: 19
    Last Post: 11-02-2008, 08:49 AM
  4. FX SHO Cavitation out of the hole
    By LS2000 Cop in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 10-06-2008, 07:19 PM
  5. cavitation out of the hole
    By daverxp4 in forum 4-Tec Performance
    Replies: 36
    Last Post: 05-28-2008, 07:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •