Results 1 to 5 of 5
  1. #1

    96 gsx electric issues

    96 gsx. Ran great. Wear ring went out and they have sat for almost 2 years. Put the key on and hit the start button. All that happened was the light on the dash lit up. No beeps or clicks. I have checked the two 5 amp fuses amp the 15 amp in the front box and the 7.5 and 10 amp in the back. All good.

    Took the plugs out and jumped the post on the relay and it spun over. I tried to do a compression check but with the tester in. It acted like it doesn't want to spin over. Battery had 11.8 volts. I haven't pulled the front cover on the motor (flywheel).. Even if I did I wouldn't really know what to look for. Also. The light will come on on the dash just by putting the key on without hitting any buttons. So I feel like it's recognizing the key.

    I also put the plug back on the wire to check for spark. No spark. The plugs have been in there awhile so that might have something to do with it. Any and all help is appreciated. Thanks


  2. #2
    SELF27's Avatar
    Join Date
    May 2013
    Location
    Austin, TX
    Posts
    202
    +1
    16
    seadoo require a good battery installed in boat. sounds like you have weak battery. battery voltage should be around 12.5 surface. also common for starter solenoid to fail. unplug and check for voltage to solenoid while pressing start button. first get good battery.

  3. #3
    Just to make sure. The solenoid is the one with the +battery cable and the wire going to the starter right. Thanks for the quick reply

  4. #4
    SELF27's Avatar
    Join Date
    May 2013
    Location
    Austin, TX
    Posts
    202
    +1
    16
    yes, unplug small connector to test

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    If you get no beeps and it won't turn over and you get no spark while jumping the solenoid then it sounds like your DESS post is bad or disc inside of it stuck. Take a strong magnet like the back of an old car speaker, or pickup tool, and tap around on the DESS post with it. Then try your lanyard again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 XP Electrical issue
    By pooner in forum 2-Stroke Performance
    Replies: 6
    Last Post: 03-18-2012, 11:55 AM
  2. 96 GSX Oil issue
    By barondurden in forum 2-Stroke Performance
    Replies: 1
    Last Post: 10-13-2010, 04:26 PM
  3. 96 GSX Rave issue
    By barondurden in forum 2-Stroke Performance
    Replies: 5
    Last Post: 09-14-2010, 07:45 PM
  4. 96 sl900 electrical issues?
    By astfu in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-06-2010, 02:47 PM
  5. 96 gsx starting issues?
    By guitar jeff in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-06-2010, 10:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •