Results 1 to 8 of 8
  1. #1
    fordgt's Avatar
    Join Date
    Sep 2013
    Location
    Brisbane, Australia
    Posts
    45
    +1
    6

    FX140 impeller change has ruined speed and cavitation!

    Hi everyone.

    Just want to run this past you all for your thoughts.

    My FX140 had a Solas Concord YF-CD-12/18 impeller in it installed 6 months ago.

    Since then the wear ring has developed a high spot in it which took the edges off it and you can hear it touching the edge.

    I took it in to get serviced and new impeller/ring, and they said we'll pit a Skat impeller in as it's the only one in stock at the moment. On the invoice it says "Skat Trak 13/19 155-XL.

    I took it out on the river after picking it up and it feels like it has lost both off the line pickup and its lost about 10km/h of top speed. Mid range is ok, but I'd rather have it revving less at cruising speed than midrange pull.

    My question is do you think this is solely because of the design differences between the impellers, or is ot possible they may not have installed it correctly? I am no expert, but I noticed the difference straight away.

    I pulled off the ride plate and the intake grate to have a look and it looks ok apart from one bolt missing holding the wear ring on to the part it bolts to. Not ideal, but seems solid enough.


  2. #2

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    If they have a wear ring bolt missing that is not good! The wear ring and all bolts need to be instaled. also if they did not seal the wear ring good to the transom it will suck in air at the transom/ wearing contact points and it will cavate real bad on takeoff. sounds like you need to take it back for a recheck of there poor quality instalation, Also the higher pitch prop ( scat 13/19) is pretty high for a fx and won't let you ski reach max rpms, Tommy Jordan

  3. +1 by:


  4. #3
    silver93t's Avatar
    Join Date
    Jun 2012
    Location
    NJ
    Posts
    1,064
    +1
    49
    I also think that is too much prop for an FX140. I have one on my gpr which has quite a few mods. A stock ski wouldn't turn it.

  5. +1 by:


  6. #4
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Always remember that dealerships employ minions. A large portion of the time, they know less than the average cat.

  7. +1 by:


  8. #5
    fordgt's Avatar
    Join Date
    Sep 2013
    Location
    Brisbane, Australia
    Posts
    45
    +1
    6
    Thanks for the replies guys!

    I rang the dealership and they're going to check it later this week.

    1' pitch more should have the revs lower obviously, hopefully not too much to be unworkable, so once they re-seal the pump I'll see how it goes. The old Solas hooked up well and pulled strongly up to 95km/h on the speedo, but this one, despite being 1' pitch more on paper, is hitting 10K rpm at 80-85km/h.

    This is riding at sea level too if that makes any difference.

    I'll let you know how I go and thanks again for the advice!

  9. #6
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    You belong to the Best PWC Forum in the World....about time you learned to work on your own skis....That way you know its done Right....

  10. +1 by:


  11. #7
    fordgt's Avatar
    Join Date
    Sep 2013
    Location
    Brisbane, Australia
    Posts
    45
    +1
    6
    From now on Aquaholic I'll be doing just that... Saving a bucketload in the process...

  12. +1 by:


  13. #8
    fordgt's Avatar
    Join Date
    Sep 2013
    Location
    Brisbane, Australia
    Posts
    45
    +1
    6
    Well I picked it up from the dealer today and took it for a spin. Seems to be running fine again.

    They said that they replaced the Skat with a Solas 12/18 same as it had in it originally and resealed the pump.

    They also said the broken bolt was like that when they got it... I had never noticed it but then again I hadn't looked that closely before.

    Did 50km today around South Stradbroke Island, Queensland and it didn't miss a beat.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP Slow top speed, vibrations and cavitations
    By na1 in forum 4-Tec Performance
    Replies: 23
    Last Post: 07-20-2015, 03:03 PM
  2. impeller pitch vs speed and rpm
    By dodgetrucker75 in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 06-18-2012, 02:52 PM
  3. My wesco trailer has 8" tires and I want to change to 12"
    By crackofdawn in forum Towing and Trailers
    Replies: 8
    Last Post: 10-10-2011, 01:05 PM
  4. Prop boot and cavitation
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-28-2011, 08:09 PM
  5. Now this is speed and performance...
    By Fast-XPL in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-23-2005, 10:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •