Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    NEW 33 minutes on stf15 and it sounds/feels like cavitation. Please HELP!

    Hello, Let me start by saying we just purchased the Kawasaki stf15 Black and Green jet ski Tuesday from Aquatic center on Deep Creek Lake. Anyway we love it. But after 33 minutes of Easy riding the Ski Lost pump Pressure? sounds like Cavitation? We where lucky it would idle back to the trailer. If you give it gas it sounds like vibration or Cavitation. I pulled the ski out of the water and looked for debri but nothing was in it. So I dropped it back in the water just to double check and same thing. After getting a closer look It seems everything looks perfect in the pump area! so anyway I need this ski to work for memorial day as it was the whole purpose of buying it! The dealer is 2 hours away so I was just reaching out to you guys first to see if its something stupid before I make the drive. 2 times this week just to drop it and pick it up. Thanks you!


  2. #2
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Not doubting your assessment but it really sounds like something is where it is not supposed to be. It does not take much at all to cause this. Did you look from under the ski up into the tunnel towards the impeller?

  3. #3
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Id say pull the pump....even close inspection may not let you see a small piece of wood lodged between the prop and the housing.....sounds like that is what you have going on....

  4. #4
    Well You guys called that one.. I wish I had the little l.e.d Light I got at home. Stuck it up in from the bottom and boom there was a tiny piece of wood cut into the impeller and rotating with the impeller! So I guess ill be making a trip to the lake again to test it out. Its crazy what something so small can do to your day lol. Thanks Lets up this is all it was! is 62mph seem legit for this ski?

  5. #5
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Yes that is a potential speed. Glad we could help you. I know how it can be with a new ski. The frustration can make you easily overlook things. Enjoy your test run and let us know how it worked for you.

  6. #6
    merkdog's Avatar
    Join Date
    Apr 2013
    Location
    Chicago area
    Posts
    66
    +1
    15
    Quote Originally Posted by dshaff24 View Post
    Well You guys called that one.. I wish I had the little l.e.d Light I got at home. Stuck it up in from the bottom and boom there was a tiny piece of wood cut into the impeller and rotating with the impeller! So I guess ill be making a trip to the lake again to test it out. Its crazy what something so small can do to your day lol. Thanks Lets up this is all it was! is 62mph seem legit for this ski?
    I have a 2014 15F also and got 68mph out of it on flat water. Obviously that's read off the gauge and GPS is the only way to really know what your doing. I am impressed with the ski though. We have a 300X also and the 15F is not far behind it from a dead stop. I'm guessing since your issue happen after 33 minutes and you already pushed it to 62mph your not following the break in procedure?

  7. #7
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Everybody has their break in procedure.....

  8. +1 by:


  9. #8
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Hey merc, can you change your avatar please? It makes me jealous. Just kidding. I go to my dealer often and that 15F is begging me to buy it so I can be like you and have the two side by side.

  10. #9
    As for the break in procedure the dealer told me to vary the throttle. Meaning I can go wot for a short burst.. then maybe half then 3/4.. then 1/4.. Basically just keep changing it up? True or False? I love this ski. Last ski I owned was a seadoo xps back 7 years ago..

  11. #10
    Also it might go faster then 62 That was just a burst then I let off and cruised 30ish.. then idle. then wood got stuck in the impeller.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. my friend dropped my new gopro in the ocean and it sank..
    By 6spdg37s in forum Open Discussion
    Replies: 13
    Last Post: 06-05-2016, 11:30 AM
  2. I bought a 260x with "issues" and have some questions for everyone! Please HELP!!
    By BoostedV10 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 14
    Last Post: 01-27-2014, 11:15 PM
  3. Replies: 25
    Last Post: 07-31-2013, 05:41 AM
  4. new to this forum but have some problems with my js440 please help
    By dirtydave916 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-16-2011, 01:15 PM
  5. New to maintenance on myski and need a little advice
    By coyle2285 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-29-2007, 08:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •