Results 1 to 3 of 3
  1. #1
    NateRXP's Avatar
    Join Date
    May 2013
    Location
    Richmond, TX
    Posts
    746
    +1
    180

    Fuel pump install help

    After removing and re installing fuel pump after fizzle air I fired it up and my gas meter is showing no bars and beeping low fuel at me when I know I have half a tank?? I have it out now and I see an arrow on it. Is there a trick to this cuz I think the float is getting jammed somewhere. Thanks (2014 PX ) Click image for larger version. 

Name:	ImageUploadedByTapatalk1400516622.288847.jpg 
Views:	31 
Size:	36.1 KB 
ID:	329767


  2. #2
    Hey, I removed and reinstall the fuel pump since I upgrade to air kit too! I don't have that issues like you are having! My dad put the pump back in angle and stand up straight and tighten down! I make sure its line up the way that I pulled out! I don't think that arrow means anything but I could be wrong! My tank bar shows that I have half which is true!

    Click image for larger version. 

Name:	photo 1.jpg 
Views:	28 
Size:	55.4 KB 
ID:	329771Click image for larger version. 

Name:	photo 2.jpg 
Views:	30 
Size:	43.7 KB 
ID:	329772

  3. #3
    NateRXP's Avatar
    Join Date
    May 2013
    Location
    Richmond, TX
    Posts
    746
    +1
    180
    I fixed it! The little arrow has to line up with the tab on the tank. I guess the float was jammed up against the side of the tank giving me false reading. Works fine now. Click image for larger version. 

Name:	ImageUploadedByTapatalk1400518964.774044.jpg 
Views:	25 
Size:	28.0 KB 
ID:	329773

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SL 750 triple outlet fuel pump installation help please
    By Jadobmeier in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 07-04-2016, 11:41 PM
  2. Replies: 2
    Last Post: 08-15-2015, 10:25 PM
  3. 98 XPL fuel pump upgrade help!
    By peachypete82 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-07-2008, 07:31 AM
  4. bilge pump install help!
    By islandboy in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-01-2008, 08:16 AM
  5. triple ouput fuel pump install
    By jlaracuente in forum Polaris Open Discussion
    Replies: 1
    Last Post: 04-15-2008, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •