Results 1 to 5 of 5
  1. #1
    Derek45's Avatar
    Join Date
    Feb 2014
    Location
    MO. Mark Twain, LOTO
    Posts
    461
    +1
    26

    04 RXP What causes the Gauge cluster to not work when you know it does???

    yep me again gauge works was tested and seen vidio from the guy its the same Gauge that I sent back to him, worked 4/5 times on my ski then went dead halfway through last Cycle,so sent back to him, , all conections are good, 12v at purple wire and BLK. to gauge, my candoo puts up the code for missing gauge and will not reset/deleat code, tried another gauge pig tail as well.

    would this be a MPEM issue or ECU ?

    what should the 2 white/striped sending wires read on a meter, on pig tail to gauge?


  2. #2
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Location
    Bowling Green, KY
    Posts
    1,377
    +1
    162
    I have seen them work intermittently on several occasions... it probably has the typical water damage. They come and go, then shit the bed forever... Get another set of gauges to try and if they don't work either then re-sell them.

  3. #3
    Derek45's Avatar
    Join Date
    Feb 2014
    Location
    MO. Mark Twain, LOTO
    Posts
    461
    +1
    26
    I dont think its the gauge, as I said, shipped back and he took a vid of it and it was the same gauge without a doubt,, so thats why I am thinking its a MPEM or ECU issue, I would had thouight the Cashdoo could reset the MPEM, clear the gauge fault or allow me to do something, what about a new gauge it has to be programed, but if the ECU or MPEM are faulting I would not be able to do anything with any gauge.
    what should the 2 white/striped sending wires read on a meter?

  4. #4
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Location
    Bowling Green, KY
    Posts
    1,377
    +1
    162
    They go to the MPEM, I don't poke around in wires from the mpem if i can help it... but, basically there are 4 wires from the mpem to the gauges, power, ground, and 2 for data. The white wires are data i think, they won't give you anything meaningful on a multi meter, just small pulses that most cheap meters will not even read. Check all your fuses, unplug the gauges, the ski will start and run if there is nothing else wrong with it. If it runs the mpem and ecu are good, that means your gauges are definitely bad. The new gauges with the latest part number seem to be plug and play for the 07 up, i'm not sure on the 04 though. Major bummer too that the CanDoo won't program the gauge clusters... i understand your hesitation to make a trip to the stealership...

  5. +1 by:


  6. #5
    Derek45's Avatar
    Join Date
    Feb 2014
    Location
    MO. Mark Twain, LOTO
    Posts
    461
    +1
    26
    yes thanks for the info, well more issues see pics, about to throw the towl in on this , 2nd trip to lake mayby 30 mph tops, see pics. and rpms that is full throttle, so I assume this is in limp mode still? when I check the tops, oil sensor on candoo, I get a click then shortly after another like it closes click, every once and awhile I hear a double click then another like it clicks shut, gauge volts at purple wire to gauge/ground is over 12v, on White striped 2 wires they read at ohm setting 20 at 3.10

    Click image for larger version. 

Name:	20140520_131116.jpg 
Views:	34 
Size:	132.2 KB 
ID:	329895Click image for larger version. 

Name:	20140520_131133.jpg 
Views:	35 
Size:	130.7 KB 
ID:	329896Click image for larger version. 

Name:	20140520_131156.jpg 
Views:	31 
Size:	140.7 KB 
ID:	329897

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. stock 04 rxp what should the sc slip be?
    By b_dolla44 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-07-2011, 10:25 AM
  2. 04 RXP (155 hours) Need Help On ECU not working correctly.
    By davidrxp in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-21-2010, 01:03 AM
  3. 04 RXP (155 hours) Need Help On ECU not working correctly.
    By davidrxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-21-2010, 01:02 AM
  4. What is an 04 RXP worth on the open market?
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-08-2006, 08:37 PM
  5. What would cause the hole shot to decrease?
    By Ed in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 06-30-2005, 05:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •