Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16

Thread: Engine light

  1. #1

    Engine light

    Hey guys , newbie here ,
    I have a spark which i absolutely love but i have started to have an issue with it ,
    recently the engine light has been coming on whilst decelerating , i then have no power and it will only do 25-27 mph , if i turn the ski off and restart it goes back to normal although the acceration isnt as great i can get it back up to full speed until i decelerating it cuts again . It doesnt happen all the time but it happening more frequently now .
    Has anyone else had this issue or know of possible cause ?
    Any ideas thoughts would be greatly appreciated , cheers .


  2. #2
    xdrian's Avatar
    Join Date
    Nov 2008
    Location
    Brisbane Australia
    Posts
    898
    +1
    225
    sounds like its going into limp mode

    if you have a Maptunner you could look for error codes

    if not back to dealer

  3. #3
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Sounds like oil pressure sensor faulty

  4. #4
    Quote Originally Posted by GasResearch-VT.SE View Post
    Sounds like oil pressure sensor faulty
    Why does that happen?

  5. #5
    Quote Originally Posted by Cheappc View Post
    Quote Originally Posted by GasResearch-VT.SE View Post
    Sounds like oil pressure sensor faulty
    Why does that happen?
    Bad sensor


  6. #6
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Sounds like you need to quit riding it till you figure out what the problem is....its not going to fix itself....

  7. +1 by:


  8. #7
    I'm also having the same problem

  9. #8
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Hey guys, not trying to be smart but:

    Theres no point going "Hey I got a CEL but can you guys tell me what it is..." etc...

    You need to get the fault code, then we can help.

    Theres 3 ways to get the fault code out:

    --Using BUDS kit from a seadoo workshop
    --Using VTECH maptuner to read codes
    --Using candoo or similar

  10. +1 by:


  11. #9
    I figured out my problem I had trouble reading key main connector was dirty

  12. #10
    Quote Originally Posted by Haroldspark View Post
    I figured out my problem I had trouble reading key main connector was dirty
    Its a magnet?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help, Check Engine Light, Error Code P0344
    By JC7727 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-14-2007, 06:27 PM
  2. Check engine light
    By mooneyb91084 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-20-2007, 12:26 PM
  3. Check engine light! Not pulling a code... HELP!!
    By Venator in forum 4-Tec Performance
    Replies: 10
    Last Post: 12-10-2006, 07:58 PM
  4. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM
  5. Check Engine Light
    By meeper in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-27-2005, 04:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •