Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Sep 2013
    Location
    Southeast Texas(near Cut-&-Shoot Texas)
    Posts
    85
    +1
    1

    40mm carbs on 1996 sl900 slow to mid bog

    I have rebuilt the 40mm carbs with new kits.Revs good out of water,in water idles good. But from1500 to 3500 rpm bogs,(1/4 throttle to full bogs). Pump the throttle fast 3 or 4 times gone 6400 to 6500,runes great.Slow to 3500,won't cruse, bogging,pump the throttle 2 or 4 times gone again 6400 6500 runs great.If bogs and dies, it hard to start.I think this wood slow to mid range bog.Pop off pressure is 24 to 26,needle is 60 maybe 65,it hard to get just dead 60,could this be a problem? Help please sandonut


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    40s are bigger than the stock 38s. You probably need a bigger low speed jet. Whats in it now for jetting?

  3. #3
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,777
    +1
    405
    accl pump isses,its bleeding down the fuel inside the metering block when it idles.either the metering block check ball isn't seating or its one of the brass squirter balls.thats why you can blip the throttle a couple times,refill the block and it runs great

  4. #4

    Join Date
    Sep 2013
    Location
    Southeast Texas(near Cut-&-Shoot Texas)
    Posts
    85
    +1
    1
    BryanP the jets are main M=140 C=140 135...,Med.=35 Slow=62.I did set the pop off pressure at 24 to 26. Could that cause the slow to med bog? Cruising at WOT is great, but does not like 2000 to 3500 bogging.

  5. #5

    Join Date
    Sep 2013
    Location
    Southeast Texas(near Cut-&-Shoot Texas)
    Posts
    85
    +1
    1
    accl pump not squirting from idle to 1/2 throttle explains the blipping of the throttle to take off,but what about cruising at 2000 to 3500 rpm?

  6. #6

    Join Date
    Sep 2013
    Location
    Southeast Texas(near Cut-&-Shoot Texas)
    Posts
    85
    +1
    1
    These carbs are off a 1999 sltx 1050 and or on a 1996 sL 900,just a reminder. hey never seen the check ball in the carbs,Could be a problem with the blipping.Thanks for the input.

  7. #7
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,777
    +1
    405
    get the accl pump fixed and the issues should disappear,might look into going with a later style water cooling routing as well

  8. #8

    Join Date
    Sep 2013
    Location
    Southeast Texas(near Cut-&-Shoot Texas)
    Posts
    85
    +1
    1
    Yep! That darn little ball in accl. pump was leaking bad.Well changed the block,reset needle height,and pop off pressure.WOW! wot 6550rpm MFD 49-50mph!!! Still have the mid 2500 to 3500.I set the low speed jet (adjustment screw) to 1 3/4 turns out.After riding a bit,15min. or so,shut the machine off. Hard to start.Maybe low speed adjustment? Maybe take care of med range too. This is the 1997 780 slt I worked on all summer,never got on plane.Pulled 780,installed 96 sl 900, installed in 780 hull.Man same thing??? But thanks to you boys @ my hard head WE got her by the prop now.Man 447 said,(sound like fuel to me ),I'm just hard headed.Thanks a million Sandonut.....................1997 780 slt-96 sl 900- 1999 sltx 1050 40mm carbs running good!

  9. #9
    Miglater's Avatar
    Join Date
    Apr 2013
    Location
    Howell, MI
    Posts
    424
    +1
    25
    I'm no engine/carb guru but, the 2500-3500 sounds like the typical flatspot right before the powerband hits. My 900 does the same thing, it's like an on/off switch once ya get to 3500+ if i recall correctly, this is due to how the pipe is tuned.

  10. #10
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Your mid jet is too small for a 900. Look at the stock jetting for a 900. And why did you change the 38s for 40s? The 38s are plenty for a stock 900.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. carbs on a 97 compared to 96xp....
    By Stagesrt4 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-09-2010, 10:47 AM
  2. UREGNT**Can I use 40mm carbs on a 1996 sltx 1050
    By motox1027 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-22-2009, 06:37 PM
  3. getting the rxp to mid to high 70s on a budget
    By spence in forum 4-Tec Performance
    Replies: 8
    Last Post: 10-01-2008, 05:44 PM
  4. How to identify different Mikuni carbs on SL780
    By martinv in forum Polaris PWC Performance
    Replies: 10
    Last Post: 05-08-2007, 01:35 PM
  5. How to tune 3 carbs on SL750?
    By joeyjunio in forum Polaris Open Discussion
    Replies: 31
    Last Post: 03-20-2007, 11:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •