Results 1 to 3 of 3
  1. #1

    Join Date
    May 2014
    Boca Grande Fl

    02 gtx 4 tec injector problem

    Hello all. I just purchased a 02 gtx 4 tec. Was out riding and happened to flip the over in salt water. Was able to flip it back over and swim it to shore. Pulled plugs out and drained water out of the hull. Water was up to the middle of the battery. Got ski to fire up and rode it back to the ramp. Ran fine. Got home and changed oil. All was good no water in oil. Took it out to run the next day and ran great for a half mile then bogged down. Got towed back. Pulled spark plugs and #1 cyl filled with gas. Pulled injector rail and put key on and gas squirted out of # 1 injector for 4 seconds then stopped. Continued to squirt everytime i hit the start button. Switched injector for number 2 still squirting out of number 1 spot. Pulled all connections, fuses and blew compressed air into them. Any ideas? Thanks

  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Davison, Mi
    probably junk in the gas tank has got in the injector and jammed it open
    send out for rebuild or buy new

  3. #3

    Join Date
    May 2014
    Boca Grande Fl
    Fixed my problem. Bad ECU was causing the injector to stick open.. Thanks for all who helped especially Joe w

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 gtx 4 tec ecu or injector problem
    By BocaBoyz in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-28-2014, 05:20 PM
  2. 2006 seadoo gtx injector problem
    By sheebaracer in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 03-02-2012, 02:23 PM
  3. 02 GTX DI injector problem
    By dtfly in forum 2-Stroke Performance
    Replies: 9
    Last Post: 06-17-2010, 10:31 PM
  4. GTX 4-Tec - ugly problem engine to pump or pump to engine
    By richard kagen in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-13-2009, 11:17 PM
  5. '06 Sea Doo GTX 4 Tec Battery problems!
    By ohanaporvida in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-01-2007, 06:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts