Results 1 to 6 of 6

Thread: No power on RXT

  1. #1
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    876
    +1
    23

    No power on RXT

    Took my 2008 RXT out for the first run this year. Got about 100 yards from the dock and shuts off like someone turn off the key. Tried to put dess key in again and nothing. No gauges or beeps.

    Loaded up and went home. Check all fuses, battery, cables and grounds. I have 12. 6volts from battery + to Ground. I assume there is a roll over potection circuit somewhere. Would that cause a no post? Also thinking about dess post. But seems that is unlikely.

    Any other ideas?


  2. #2
    In 9/10 cases with new problems at start of season it's either battery or fuel. If it ran ok up until storage and you haven't done any specific work on it during off season.

    I would start with deep charging battery / swapping out to a new one. The voltage is only one part of the story. If the battery is old, then it won't have the same strength (amps). So seeing 12v on a meter means nothing. You should measure volt whilst cranking (or attempting to) if possible. However, if you can't get a beep then you're stuck there.

    If with a new known good battery the problem remains I'd start by looking at the DESS post.

    Either the reed switch or magnet are not working as they should. Try other key (learner) if not then maybe the post is the issue.

  3. #3

    Join Date
    May 2014
    Location
    Florence Alabama
    Posts
    19
    Check the solenoid beside the battery. Has two red cap wires plugged into it. I had to replace mine on my 08 RXT-X with 12 hours on it. It was having the same symptoms

  4. #4
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    876
    +1
    23
    Interesting. I'll give it a look see. Wonder why a solenoid would cause the computer to no wake up. Maybe thats where the power comes from?
    I'll let you know.

  5. #5
    I had similar when my solenoid went. Was riding all day starting 15-20 times. Got to dock and died before I pulled key. Was making a small background humm inside. Then key and nothing worked. Replaced solenoid and things were fine.

  6. #6
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    876
    +1
    23
    You guys were right on. Went to the solenoid and found one of the small wires going into the one of the screws was broken off of the wiring ring. Crimped on a new ring and fired right up. Thanks for the all the help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help No power on 1997 gts
    By Seakid in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-20-2015, 07:59 PM
  2. 09 RXT iS no Power/Lights on display
    By aha in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-26-2014, 05:08 PM
  3. No Power On Electronic System
    By DeepWave in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-19-2012, 05:36 PM
  4. no power on STX 1100
    By chiefmoose in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 08-08-2008, 10:56 PM
  5. HELP. RXT power on without lanyard...
    By BoostedH23a1 in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-03-2007, 01:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •