Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    2013 VXR cavatation on take off

    I have a 2013 VXR that I recently installed a performance kit in and anything over about 90% throttle on the hole shot it will bounce the rev limiter due to cavitation. The ECM was reprogramed to stg. 1 and added 12-19 scat impeller. I was meticulous installing the new grate and seal kit and touched all areas that could suck air with silicone. When I installed the ride plate R&D ride plate it had .080 step from plate to pump intake. I always heard closer to flush is better but not past flush. I shimmed all 4 ride plate bolts .065 to bring the difference to .015. I did not change the angle yet but probably will add shim to rear since I get some front end bounce at 70. I did not seal the ride plate to the pump. And am thinking sealing it may help. But do not know. And would like to know what sealer is the best to use on pump grate & ride plate. And am open to any other input that would help with my cavitation issue & tips for getting the most out of this ski. Oh handling with the new ride plate is great when carving the water up.


  2. #2
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    Welcome to the hulk.......u need to angle your ride plate .some people remove factory shims completely. What are u using to get your mph? Hopefully a gps because the dream-o- meter is not accurate.. if u lean over the bars on launch does the cav fade? A 12/19 isnt a prop i have heard too many people using. Where did u come up with using that pitch? I ask because i am just starting with a reflash and it has set me back alot.

  3. #3
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    Also what rpm's are u running at? If u havent yet i would invest in a aftermarket tach to get optimum readings. A tiny tach is a good start for the $ but if u are going to build more u might want to invest a little more. Ck out the vxs/r mod database above and also known issues thread for these skis. Lots of good proven info for u to use...

  4. #4
    taking into consideration that you are using all the right parts i think you may be experiencing a normal level of cavitation for your level of mods.coming from the supercharged side of the forum i can tell you a 100% cure which is what i feel you are in search of is usually an expensive one and may be difficult to accomplish without reducing your top speed since your ski is NA.i would pitch the leading edge of your prop up and try the TBM cone.
    Last edited by FXSlowKroozer; 05-23-2014 at 10:22 AM.

  5. #5
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    The Riva intake grate gets rid of cavitation, but it also scrubs 1 MPH off on the top end. It's always a tradeoff.

  6. +1 by:


  7. #6
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    how many times does it hit the limiter ??? if its only two or three times, let it fly, your not going to hurt the motor, i've got 160 hrs of beating the dog snot outta my NA motor, and it runs like a fine rolex

  8. +1 by:


  9. #7
    Just relax and enjoy the ride. XLT Chad's Avatar
    Join Date
    Jan 2011
    Posts
    1,284
    +1
    116
    If you've sealed the shoe and your still actually getting cavitation you may need to reseal your transom plate. It's been found that Yamaha doesn't do the most thorough job of sealing this at the factory, and you could have some gaps in the sealant. Mine only had about 75% of the surface covered. Resealing it and filling the voids it has could help.

  10. #8
    The kit i used was R&D stage 1 from the web store. The impeller is the recomended one from Scat & Jerry and also came from the web store. I think I will check out the transom seal and intake grate again. It stayes on the rev limiter for a few sec. if I stay in it. But less then WOT & hello were launched. If the rresealing does not work I probbaly will try a differnt grate. What is the best sealer to use on the grate? I have the seal kit and used windshield RTV when I installed it

  11. #9
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    3m 5200 sealant

  12. #10
    bryantjopplin's Avatar
    Join Date
    Jun 2012
    Location
    Shreveport, LA
    Posts
    2,436
    +1
    163
    Quote Originally Posted by Oldman on VXR View Post
    The kit i used was R&D stage 1 from the web store. The impeller is the recomended one from Scat & Jerry and also came from the web store. I think I will check out the transom seal and intake grate again. It stayes on the rev limiter for a few sec. if I stay in it. But less then WOT & hello were launched. If the rresealing does not work I probbaly will try a differnt grate. What is the best sealer to use on the grate? I have the seal kit and used windshield RTV when I installed it
    Mine in all sealed up soup to nuts, still have cavitation for about 5 seconds on any of my 4 grates, so don't just buy another. Its going to be your prop, bet it. Your going to have to suffer top speed for take off. Probably need a 14/20 or 13/20 but suffer top speed

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP1200 Bogging on take off only. Any Advice?
    By Danimal2k5 in forum Yamaha Old School Skis
    Replies: 24
    Last Post: 05-28-2010, 01:14 AM
  2. GP1200 Bogging on take off only. Any Advice?
    By Danimal2k5 in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 05-26-2010, 09:27 PM
  3. SLT 780 hesitates on take off
    By paramuir in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-08-2008, 08:57 AM
  4. Massive Cavation on Take off (Ultra 250x)
    By Scott in forum Kawasaki PWC Performance (4-stroke)
    Replies: 20
    Last Post: 09-06-2007, 08:49 PM
  5. 14 hours, lost 200 rpms, hesitates on take off and bad vibration
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 08-13-2007, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •