Results 1 to 9 of 9
  1. #1

    Join Date
    Jul 2007
    Location
    western ky
    Posts
    65

    Genesis I stops short of wot

    2001 genesis i acceleration stalls around 4500 rpm can feather throttle abit and will run great wot.any idea what's going on ?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,602
    +1
    1,277
    What diagnostics have been done?

    Has the TPS sensor been changed?

  3. #3

    Join Date
    Jul 2007
    Location
    western ky
    Posts
    65
    No diagnostics yet.still has old style tps I have a 2003 genesis with the pigtail tps will it fit the 2001?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,602
    +1
    1,277
    Quote Originally Posted by mgm1966 View Post
    No diagnostics yet.still has old style tps I have a 2003 genesis with the pigtail tps will it fit the 2001?
    You can adapt the old style throttle body shaft to accept the new style pigtail TPS. I may have posted a how-to somewhere on here. Search for pigtail with my username.

    Basically you remove the small arm and tab hardware from the end of the throttle shaft. What remains is a shaft end with flat sides that should fit mate with the pigtail style TPS.

  5. #5

    Join Date
    Jul 2007
    Location
    western ky
    Posts
    65
    Couldn't find where you posted on how to convert over to pigtail tps can you direct me to it or tell me how to do it ?thanks

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,602
    +1
    1,277
    Quote Originally Posted by mgm1966 View Post
    Couldn't find where you posted on how to convert over to pigtail tps can you direct me to it or tell me how to do it ?thanks
    How to convert 1999-2001 Polaris Ficht throttle body to upgraded 'pigtail style' TPS

  7. #7

    Join Date
    Jul 2007
    Location
    western ky
    Posts
    65
    Changed tps out with the ec1098 still have same issue.starts fine idles good accels to wot sometimes apx6700 rpm.hits a stall at apx 5000 rpm can let off throttle and then hit it again and usually it will accel to 6700 rpm .any idea what to check next?

  8. #8
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check your fuel pressure. Make sure you havent lost the regulator.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,602
    +1
    1,277
    Quote Originally Posted by mgm1966 View Post
    Changed tps out with the ec1098 still have same issue.

    starts fine idles good accels to wot sometimes apx6700 rpm.hits a stall at apx 5000 rpm can let off throttle and then hit it again and usually it will accel to 6700 rpm .any idea what to check next?
    Did you verify the idle position voltage from the TPS is within the desired range?

    Specification is 0.350 volts with throttle closed, idle position.
    I have seen voltages in the .4xx range which seemed to still run properly.

    You can use the Service Power jumper method to power up the EMM without running the engine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Genesis I 1200 Loss of Power
    By 440/650 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-02-2013, 03:35 PM
  2. 3 short of my limit!
    By 504tim in forum PWC Fishing
    Replies: 16
    Last Post: 05-09-2012, 05:36 PM
  3. 03 SC GTX stop middle of Riding
    By cckeong in forum 4-Tec Performance
    Replies: 1
    Last Post: 02-17-2010, 10:03 PM
  4. Bill in Arizona to help stop spread of mussels
    By shawn alladio in forum High Performance Watercraft Safety
    Replies: 0
    Last Post: 03-04-2009, 05:03 PM
  5. 1999 1200 genesis start stop problems
    By steelehead in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-30-2008, 07:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •