Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29

    The adequetly colored LEMON yellow POS 2010 RXT-iS

    Throwing codes and electrical problems all weekend long.

    Friday - P0562, P01267

    Fixed that with a new voltage regulator

    Saturday - no start no power to dash

    Open the two fuse boxes checked all fuses and
    replaced them all ok, power comes back so something loose?

    Today - throws fault code P0117 constant annoying
    embarassing beep and limp mode all the way back to dock.



    Day ruined...pissed!


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    The PO117, is the head temp sensor shorted to gnd. That will probably cause it to go into limp mode.

  3. #3
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92
    You're having terrible luck with this. Didn't you just buy it?

  4. #4
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Yes

  5. #5
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Going to replace the temperature sensor (another $75) and pray
    thats the problem. Seems like a fairly easy job with a deep socket.
    Anyone got the size? Looks to be about 18mm

  6. #6

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    626
    +1
    17
    sent you a pm

  7. #7
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455

    The adequetly colored LEMON yellow POS 2010 RXT-iS

    Wow wtf

    Bring it north and I'll take care of it

  8. #8
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Yea thank God my Dad and I are pretty handy. We've were all over this thing all weekend. I just hope I can get it to a point where it stops and I can actually ride the ski and have faith in it especially when I take my kids and nephew out.
    My 07 had ZERO problems for 3 seasons of riding every weekend.

  9. #9
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455
    Any signs of the ski being sunk? Odd you have all these random code out of no where.

  10. #10
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    I am the 3rd owner and of course that subject has crossed our minds but before I bought it but I did a pretty detailed internet search on the HIN and it all checked out with no history of salvage or submersion.

    I did notice if you pop the rear boarding platform hatch while your on the water even a little tiny wave could wash into the rear compartment and bilge (if the bins were out) all over the electronics back there (battery, starter solenoid, voltage regulator, 2 fuse boxes, ecm) luckily I had the bins in when I did it so it just filled those. Point being maybe someone did that and
    it killed my voltage reg. Thing was crusty looking.

    Click image for larger version. 

Name:	10384904_10202062577390642_4863995986393346736_n.jpg 
Views:	39 
Size:	177.6 KB 
ID:	330449

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 RXT iS Issues...possibly big ones?
    By Pro-pulsion in forum 4-Tec Performance
    Replies: 20
    Last Post: 12-14-2012, 12:20 AM
  2. FS OEM 2009 2010 GTX IS 2009 2010 RXT IS Cover
    By DTHOMAS912 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-19-2012, 05:32 PM
  3. 2010 RXT iS ECU part numbers
    By RayinJapan in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-28-2010, 01:13 AM
  4. 2010 RXT-IS and SC Washers?
    By drober30 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-28-2010, 09:31 PM
  5. New 2010 RXT iS on the way...
    By RayinJapan in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-09-2010, 07:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •