Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1

    Join Date
    Jul 2012
    Location
    Fresno, CA
    Posts
    51
    +1
    1

    2012 rxt 260 lacks power vs 08 rxt 255

    Ok so I have a question and hopefully as always you guys will be able to help. I have two skis an 08 rxt 255 and a 2012 rxt 260. Long story short I posted a while ago that my family member submerged the 2012 to the point it almost sank. A friend of mine changed the oil flushed out water etc and its back in use he took it out for his troubles. So here's my question my 08 rxt flies takes off and goes the initial take off and power seems more than the 12 even in sport mode. I'm wondering if this is due to me not having the 10-20 hr service yet or if its a reflection of it almost being sunk. The dealership said the super charger should be rebuilt but I think they were up selling me. My feelings were that the 12 should be more powerful and have that take off like the 08 but it lacks that so let me know is it a setting maintenance or a larger issue. The ski seems to idle rough as well and I notice the control cluster shakes a lot in use I'm just worried because I've heard the 260 was a beast I've yet to feel that. Thanks


  2. #2

    Join Date
    Jul 2012
    Location
    Fresno, CA
    Posts
    51
    +1
    1
    Really would like some insight please.

  3. #3
    captain slow Turbo Retro's Avatar
    Join Date
    Jun 2007
    Location
    Australia - perth
    Posts
    1,679
    +1
    164
    have you checked spark plugs etc?
    what exactly did your friend do to fix it?
    how was it submerged? and was the engine running?

    you have to provide more.info

  4. #4

    Join Date
    Jul 2012
    Location
    Fresno, CA
    Posts
    51
    +1
    1
    I Posted last year that the ski was flipped over by family they didn't know how to flip it back over so water began to fill it up and only the nose was out of the water until we got it up out the water. It filled the hull. I'm not a mechanic apparently he changed the oil did the flushing no spark plugs were changed and I haven't done the service on it yet. The engine was running but I assume when they flipped over the key detached so if you meant was it on while submerged no. Sorry for bad info it was a year I go I just realize my ski isn't right I will know more Friday when I do the service but dealer talk and what's real is always difficult. Also I've never had a chance to ride the 12 broken in and don't know if it should be less powerful or sluggish than the 08 I assume the 12 would be better which is why I'm asking if what I'm experiencing is abnormal. The 12 should out perform the 08 right? Sorry again

  5. #5
    captain slow Turbo Retro's Avatar
    Join Date
    Jun 2007
    Location
    Australia - perth
    Posts
    1,679
    +1
    164
    yes, u should have same acceleration as your 08 ski, if not more.

    but you need to get the charger out and check everything. if it was me, a borescope to check the intake and exhaust valves as well.

    my rxp had some water in it from being towed. nothing major, but it was running rough etc.. smoking for a while, hows your oil looking on dipstick. i would not be riding it till at least the supercharger and plugs have been done

  6. +1 by:


  7. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Your ski needs to be looked at by someone that knows what they are doing.
    What are the max rpms you are seeing?

  8. #7

    Join Date
    Sep 2010
    Location
    Daytona Florida
    Posts
    607
    +1
    10
    It would help tons if you would slow down and type out what you're saying a little better. That was very difficult to read.


    spark plugs are a must on the 4-tecs, they absolutely go bad and from what I can tell, that engine got wet inside, it needs new plugs at a minimum.

  9. #8

    Join Date
    Jul 2012
    Location
    Fresno, CA
    Posts
    51
    +1
    1
    Quote Originally Posted by shore View Post
    It would help tons if you would slow down and type out what you're saying a little better. That was very difficult to read.


    spark plugs are a must on the 4-tecs, they absolutely go bad and from what I can tell, that engine got wet inside, it needs new plugs at a minimum.
    Sorry I was using my phone to reply and begin threads I apologize for the clarity of my post. I have no doubt the engine received a considerable amount of water in the hull some of which reached the engine. I don't know the exact process by which my friend got the ski back to operable. I know he mentioned flushing the oil taking out all the components and blowing them out etc.

    He used to own his own ATV, Jetski, Motorcycle repair shop so he is averse in what he's doing I just can't accurately describe the process due to my lack of acumen with mechanical parts.

    Now would spark plugs cause that lack of power and inital burst. My 08 has that burst where you hit the throttle and you are off high RPMS and up to 40-45 quick now I did buy that ski with a few mods already on it none to engine. just R&D intake grate and rear sponsoons.

    Thanks hopefully that was clear enough this time to ascertain. Ultimately I know this is my problem and not your concern I just like this forum and the infomration I receive puts me to ease a bit before taking it for service.

  10. #9

    Join Date
    Jul 2012
    Location
    Fresno, CA
    Posts
    51
    +1
    1
    Hard to say with definite certainty I don't want to say exactly but I believe I seen 4000 at about 35-40 miles, but not sure I apologize for my lack of knowledge. What I do know is that the take off isn't strong like the 08 and the ski idles rough. The oil is clean isn't dark or burnt.

  11. #10

    Join Date
    Jul 2012
    Location
    Fresno, CA
    Posts
    51
    +1
    1
    Quote Originally Posted by Turbo Retro View Post
    yes, u should have same acceleration as your 08 ski, if not more.

    but you need to get the charger out and check everything. if it was me, a borescope to check the intake and exhaust valves as well.

    my rxp had some water in it from being towed. nothing major, but it was running rough etc.. smoking for a while, hows your oil looking on dipstick. i would not be riding it till at least the supercharger and plugs have been done
    Thanks I believe when he did the process of fixing it he said that the supercharger looked in tact and that no water had been in it. I'm not sure what a borescope is again I'm an idiot with mechanical terms.

    The oil isn't burnt looked fine and the ski wasn't smoking overly just idles rough and lacks burst if that makes sense. Taking it in for service friday.

    What's the likelyhood the charger needs to be rebuilt my friend took it out after it was submerged in water and said it looked in tact?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 rxt 260....more power?
    By Rptuned in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-06-2016, 11:44 AM
  2. Difference between 2010 RXT X 260 vs. 2012 RXT X 260
    By WY Sea Doo nute in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 01-21-2015, 05:39 PM
  3. 2012 RXT 260 vs RXT-X 260
    By ktm23rash in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-02-2012, 08:26 AM
  4. 07rxt vs 08 rxt-x
    By chokehold in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-25-2007, 01:43 PM
  5. 08 RXT 215 vs 08 GTX Limited
    By paca22 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-23-2007, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •