Results 1 to 6 of 6

Thread: Oil Filter Crud

  1. #1
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38

    Oil Filter Crud

    I went to change my oil filters for the first time since purchasing this boat and found some strange stuff. Both filters were not crushed and all the bends you see were from me looking into the pleats. However the left filter looked real worn- the filter fibers looked as if someone took a brush to them vs the filter on the right that looked normal to me. Both were oem rotax filters. Now for the very odd part. In both filters there were some black flecks, they were too small to even try to tell what they were. Has anyone seen this happen? Both engines run and have good compression. I went ahead and checked the air intake tube and it was clear, removed the airbox and was clean too. Removed the rectifier in both and found a few placed where the black paint was chipped off and missing. Could this be the paint in the filters? I would think that would not find its way into the oil but I could be wrong. How hard is it to check the oil screen on the engine?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20140524_155844.jpg 
Views:	37 
Size:	122.8 KB 
ID:	330441   Click image for larger version. 

Name:	left 2.jpg 
Views:	43 
Size:	153.4 KB 
ID:	330442   Click image for larger version. 

Name:	left.jpg 
Views:	42 
Size:	138.2 KB 
ID:	330443  


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Isnt that the same motor that you say your tops valve is acting up?
    You got problems.

  3. #3
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Yea same motor BUT both motors had this black stuff, wasn't a lot but enough to see........any ideas? Only other thing I could see in the oil filter housing was black overspray from when the engine was painted. Could that be flaking off? Its not metal from what I can tell.

  4. #4
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Anyone else got any ideas what this stuff might be?

  5. #5
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    just a guess but it maybe some of the Teflon coating from the head gasket?????

  6. #6
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    IS that normal? I know my head gasket is not blown.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. p/n oil filter
    By godfather in forum Sea Doo How To & FAQs
    Replies: 12
    Last Post: 09-28-2007, 02:54 PM
  2. Metal inside Oil Filter
    By Shibby1485 in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-03-2006, 07:06 PM
  3. How To: Make A Oil Filter Cover Removal Tool
    By 1FastTrespiper in forum Sea Doo How To & FAQs
    Replies: 0
    Last Post: 09-17-2005, 09:44 PM
  4. oil filters
    By Lurker in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-19-2005, 06:46 PM
  5. RXP Oil Filter
    By seadawg in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-15-2005, 01:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •