Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29

Thread: HELP!

  1. #1

    Join Date
    Jul 2012
    Location
    Philadelphia
    Posts
    32

    HELP!

    So I got a fx sho riva stage 2 and ecu re flash, did a full oil change a few days ago took down the river everything seemed to be good, a few min later power loss, thought something got sucked in check the prop and all looks good. Took it out the water rechecked again and still everything turns to look good. Started out the water rpm go all the way up without a problem. Took it home check the oil level again seemed to be a bit over the top so I took some out rechecked the levels and they are all good. Also opened each of the spark plugs to make sure they didn't flood and everything is dry. Too the blow off valve out and there was a bit of oil there cleaned it up started again rpm go all the way up without any problem. Took to the river again and same story under pressure doesn't go above 8-9k. Anyone got any idea what possibly can it be before I'm gonna take everything a part and check every component? Thanks in advance!


  2. #2

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    you should be only at 8850 rpm's max with a reflash .check your clutch, should only turn one way, check you boost pipes too incase you have an air leak. if all seems good check your compression.

  3. +1 by:


  4. #3
    64physhy's Avatar
    Join Date
    Aug 2010
    Location
    Weatherford, TX
    Posts
    1,725
    +1
    168
    8-9k is a big range. Your reflash should only allow 8650-8850, depending on which reflash you have. If you're over 8k, it's probably not the SC clutch. Too much oil could cause it, so check it again, and make sure there's not still some residual oil in the intake. It's actually better to run these slightly low than it is high.

  5. #4

    Join Date
    Jul 2012
    Location
    Philadelphia
    Posts
    32
    I checked all level everything seems to be ok there anyone else got any idea what can it be before I'm take it to pieces lol how can a super charger be checked without being taken out

  6. #5

    Join Date
    Jul 2012
    Location
    Philadelphia
    Posts
    32
    Also how do I check the clutch?

  7. #6
    64physhy's Avatar
    Join Date
    Aug 2010
    Location
    Weatherford, TX
    Posts
    1,725
    +1
    168
    It's not the supercharger or the supercharger clutch. If it was, it wouldn't go above 5-6k.

  8. #7
    KamikazeGPR's Avatar
    Join Date
    Mar 2007
    Location
    Philadelphia
    Posts
    1,361
    +1
    99
    Quote Originally Posted by volume16 View Post
    Also how do I check the clutch?
    Where are you in philly. Disconnect air hose to front of supercharger. reach in(with ski off) impeller should turn left, but not right. If it turns both ways your clutch is toast.

  9. #8

    Join Date
    Jul 2012
    Location
    Philadelphia
    Posts
    32
    In water under pressure it doesn't go, out it does

  10. #9

    Join Date
    Jul 2012
    Location
    Philadelphia
    Posts
    32
    I'm in bucks county actually

  11. #10
    KamikazeGPR's Avatar
    Join Date
    Mar 2007
    Location
    Philadelphia
    Posts
    1,361
    +1
    99
    I'm no super mechanic. But, I work on my own ski and friends sho's( bolt-on stuff) We all pretty much have the same mods with R&D reflashes. If you need local help. We can meet you at a ramp. Either linden ave or neshaminy.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-18-2005, 07:49 AM
  2. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM
  3. help!!!
    By jonstephens in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2005, 10:47 AM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •