Results 1 to 2 of 2
  1. #1
    Bogger's Avatar
    Join Date
    Oct 2012
    White City , FL

    New season - new problem

    Hello guys, You all were a great help last year,I thank you again. I do however have a new dilemma. I started my ski ( 12 rxt-x ) it started and immediately went into gear and crept forward at 2000 rpms, the engine light came on as well as the light in the upper left corner of the right cluster. there was no throttle response at all. I shut it down and restarted it about 10 times with the same problem until finally it ran properly for the rest of the day. Two weeks before the same thing happened one time and i didn't think anything of it. Now the funny part, i swear it had 98hrs on it ( I'm slow but not stupid ) after all this i noticed several lower hours. Any ideas ?. Called the dealer and they are backlogged with an excuse it has a temp sensor recall that could cause the problem (Bull). I'm thinking the module. Any recalls voluntary or non on my machine?
    Thanks, Bogger

  2. #2
    spouk3's Avatar
    Join Date
    Mar 2012
    Montreal, QC, Canada
    There's the MAT sensor recall for sure... Maybe that's the issue... Are you going in limp mode? You got an error code? Check the ibr... Maybe something is stuck in it... Try to move it up/down with the override function in the menu...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Owner, New season, New problems
    By PPro1200 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-12-2010, 11:46 AM
  2. new ultra horizontal problem
    By branix in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 07-06-2008, 06:06 PM
  3. New parts-New Problems-need help
    By HoopsRXT in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-11-2007, 04:44 PM
  4. New Day- New Problem
    By idizzy in forum 4-Tec Performance
    Replies: 22
    Last Post: 07-17-2006, 05:47 PM
  5. New day...New problem
    By idizzy in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-05-2006, 12:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts