Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    95 seadoo spi no top end power

    my 95 seadoo spi feels like it doesn't have any power above 3/4 throttle. I replaced the fuel lines, bypassed the fuel selector switch and water separator incase of the o ring leaking air. cleaned carb and put another filter before the carb. took it out on the lake today running much better when i bypassed the separator and fuel switch doesn't shut off anymore. but doesnt make any power past 3/4 throttle and sounds like a hesitation on top throttle. also sounds similar to as if you were pulling a heavy load and try to accelerate in the water. carbs is set to 1 1/4 out of low needle and 0 on high speed needle. let me know if anyone has any suggestions cause i am stumped. runs good except for top end.


  2. #2
    95 spi's don't have much top end. What rpms are you hitting? What speed gps?

  3. #3
    not sure but once you get past half throttle it feels like it doesnt go any faster and the skip sounds more noticable. such as when you give it more throttle its will sound it but will not go any faster

  4. #4
    not sure if its a engine issue or just cavitation

  5. #5
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Location
    Bowling Green, KY
    Posts
    1,376
    +1
    162
    Sounds lean... it will be devastating to the motor if you keep running it that way. Check for air leaks and pull the carbs again and check the filters. You can also back the high end needles out 1/4 turn at a time to see how that helps.

  6. #6
    whats the max i should go out on the high speed needles??

  7. #7
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Location
    Bowling Green, KY
    Posts
    1,376
    +1
    162
    If they call for 0 out then going to 1/2 or even a turn out is no biggie, but there is something else probably wrong if 1/4-1/2 doesn't fix it.

  8. #8
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    I'm guessing the crank seals are starting to dry up and leak air. Try highs out 1/4-1/2 turn as suggested. If it runs much better then it's time for a total teardown.

  9. #9
    tried it still doing it. with high screw out as suggested didnt rly make a difference. its not terrible not any hestiation or power loss just doesnt sound smooth as it should at WOT

  10. #10
    could this be ignition related?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 Spi poor top end power SOLVED!
    By kecheme in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-23-2012, 10:26 AM
  2. No low end power
    By DanHall in forum Polaris Open Discussion
    Replies: 17
    Last Post: 10-10-2008, 08:30 PM
  3. '95 SL 650 STD Top End
    By DanHall in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-27-2008, 08:12 AM
  4. SLTH CARB NEED TUNING AFTER REBUILD HOW? (no top end screw)
    By WILLF in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-26-2007, 12:32 PM
  5. HELP... Yamaha XLT 1200 No top end!
    By welterracer in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 03-22-2007, 09:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •