Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1

    Yamaha VX110 40hrs prop hitting housing?? Please help

    Hello everyone I have a 2008 vx 1100 and it was making a lot of noise I pulled the pump and found score marks in the housing and the prop is ground down on all the blades. The ski only has 40hrs on it what parts would you recommend replacing I cannot feel any play or rough bearings in the pump housing.

  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Old Hickory,Tn
    Do you leave in the water or on a lift? Salt or Fresh water?

  3. #3
    Yes it sits on floating dock saltwater.

  4. #4
    It seems to always hold water in the hull I removed the shaft and coupler to reseal that to the hull as I have seen in other posts

  5. #5
    leejax01's Avatar
    Join Date
    Apr 2011
    Is the impeller hitting the wear ring? If so, corrosion pushed it out and will need another wear ring. Probably another impeller of too much has been ground down and outside gap spec.

  6. #6
    Click image for larger version. 

Name:	image.jpg 
Views:	76 
Size:	110.6 KB 
ID:	330854 Yes here is a pic of it

  7. #7

    Join Date
    Mar 2014
    Siesta Key, Fl
    If you are leaving it on a floating dock with saltwater I would look at replacing it with either a full SS setup or a plastic one so that you do not have the dis similar metals issue with the stock one that causes the ring to get high spots

  8. #8
    Ok cool thank you so that is what caused this corrosion made high spots under the wear ring?

  9. #9
    Guidoo's Avatar
    Join Date
    Jul 2011
    Living outside of Charleston SC.
    From what I can tell. It looks to be in the same area as the mounting bolts. Water has gotten around the bolts causing the corrosion.

  10. +1 by:

  11. #10
    ken02766's Avatar
    Join Date
    Sep 2013
    Las Vegas, NV
    The salt water is very bad for the bearings, that's why I wouldn't buy any salt water boat and jetski, you need to replace the impeller, bearing and housing, the VX110 doesn't use a wear ring.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha waverunner III 96 650cc problem. PLEASE HELP
    By Easa13 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-23-2013, 10:11 PM
  2. Prop Question, pros please help...
    By meeper in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-19-2008, 07:32 AM
  3. Please Help, Hit rock and Scratched Gelcoat
    By Rspeed in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 09-06-2007, 06:00 PM
  4. Replies: 8
    Last Post: 09-01-2007, 10:41 AM
  5. please help ! 06 GPR no power , yamaha cannot resolve
    By stewartgpr in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 06-11-2007, 01:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts