Results 1 to 5 of 5
  1. #1

    Join Date
    Jul 2013
    Location
    Bahamas
    Posts
    9

    Spark plug help!

    So I've been having some very sluggish acceleration when at WOT as well as it not wanting to start yesterday. I pulled the plugs and the 2nd cylinder plug had green deposits on it. From there I swapped all out and it started up fine and once on the water it began to be sluggish at WOT again however this was an off and on thing. I just pulled the plugs (see attached). This pic was after about an hour on the water. What could be my problem?!Click image for larger version. 

Name:	ImageUploadedByTapatalk1401571710.324408.jpg 
Views:	103 
Size:	339.8 KB 
ID:	330877Click image for larger version. 

Name:	ImageUploadedByTapatalk1401571727.090232.jpg 
Views:	89 
Size:	257.1 KB 
ID:	330878


  2. #2

    Join Date
    Jul 2013
    Location
    Bahamas
    Posts
    9
    FYI I'm on a 2011 RXPX-RS with 38 hours.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Bad gas, plugs, clogged injectors
    Run fuel treatment.

  4. #4
    Tucka's Avatar
    Join Date
    Jun 2012
    Location
    mount warrigal NSW Australia
    Posts
    106
    +1
    14
    How is your coolant ?

  5. +1 by:


  6. #5

    Join Date
    Jul 2013
    Location
    Bahamas
    Posts
    9
    Coolant looks fine, not cloudy or milky. I will run fuel treatment. The gas we get here in the Bahamas is not good at all to say the least. But the plugs pictured look like water might be getting to them?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. spark plugs help
    By barondurden in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 10-24-2014, 05:07 AM
  2. Spark plug help!
    By radeon in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-24-2010, 09:48 AM
  3. Water on cylinder head/spark plugs!!! HELP ME..
    By Vesterbye in forum Polaris How To & FAQs
    Replies: 20
    Last Post: 05-23-2008, 01:57 PM
  4. Broken Spark Plug...help Please
    By ULTRA 250XXX in forum Kawasaki PWC Performance (4-stroke)
    Replies: 14
    Last Post: 05-07-2008, 12:38 AM
  5. spark plug help
    By izz0 in forum Yamaha Open Discussion
    Replies: 7
    Last Post: 09-10-2007, 10:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •