Results 1 to 9 of 9
  1. #1

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297

    question about riva ecu

    yesterday
    my engine over heat because one of my hose clamp snap on the bottom of my ski

    the problem is : i never have a alarm or a check engine
    why?

    i notice the problem when my engine start to lose power and change sound

    its a riva ecu for a 2007 rxt stage 3


  2. #2

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    maybe it did not get as "hot" as you think it did? Hook your ski up to candoo and look at your peak readings. If you are also running a 160 thermostat, just coming up to "normal 215 temps-- over temp for a 160 thermo setup", there will be a 100 rpm drop in performance and of course no codes or alarms. Did it get so hot to melt wires, burn hoses, black smoke hot or just some steam?

  3. #3

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297
    Quote Originally Posted by jim View Post
    maybe it did not get as "hot" as you think it did? Hook your ski up to candoo and look at your peak readings. If you are also running a 160 thermostat, just coming up to "normal 215 temps-- over temp for a 160 thermo setup", there will be a 100 rpm drop in performance and of course no codes or alarms. Did it get so hot to melt wires, burn hoses, black smoke hot or just some steam?
    no melt wire and no black smoke
    only steam
    i change the oil and put coolant
    im running the riva thermostate
    i think the head gasket is toast
    i did a road test yesterday and the engine running great but the coolant drop a little bit in the bottle
    maybe it was air bubble in the system because i loose all the coolant

  4. #4
    RXP TJEEZE's Avatar
    Join Date
    Feb 2012
    Location
    LOS ANGELES
    Posts
    170
    +1
    3
    Head gasket gone probably good luck

  5. #5

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    classic example of head gasket failure is the over flow translucent hose will have antifreeze traces and bottle empty. If you over filled it, that does not count.

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by jim View Post
    classic example of head gasket failure is the over flow translucent hose will have antifreeze traces and bottle empty. If you over filled it, that does not count.
    There will also be black specs in the overflow bottle too..looks like little paint chips...

  7. #7

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297
    Another test ride
    Result :
    Full bottle to max when it was cold and after the ride the Coolant drop à little bit
    No black stuff
    Put a bottle to the over flow hose and no trace of coolant
    Engine running great and have a good idle

  8. #8
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    Riva may not have turned on alarm setting i have Athena ecu i could sell you they screwed that up too

  9. #9

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297
    Quote Originally Posted by Snoman View Post
    Quote Originally Posted by jim View Post
    classic example of head gasket failure is the over flow translucent hose will have antifreeze traces and bottle empty. If you over filled it, that does not count.
    There will also be black specs in the overflow bottle too..looks like little paint chips...

    Another test ride
    Result :
    Full bottle to max when it was cold and after the ride the Coolant drop à little bit
    No black stuff
    Put a bottle to the over flow hose and no trace of coolant
    Engine running great and have a good idle

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question about Riva ECU
    By warsawspeedfreak in forum 4-Tec Performance
    Replies: 13
    Last Post: 04-24-2012, 04:27 PM
  2. Question About Upgraded ECU
    By duramaxxed in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 06-21-2009, 06:33 PM
  3. A few more questions about Riva's Stage III
    By RXPED in forum 4-Tec Performance
    Replies: 9
    Last Post: 10-09-2006, 07:57 AM
  4. Question about Riva Results on there stage II Kit? Did they
    By Water4fire in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-10-2006, 12:50 PM
  5. Question about RXP ECU
    By Pale Rider in forum 4-Tec Performance
    Replies: 11
    Last Post: 11-06-2005, 10:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •