Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    May 2014
    Location
    San Antonio texas
    Posts
    114
    +1
    11

    Help impeller clearance

    My new impeller is contacting my ss wear ring. I took out my ski after installing new impeller and every thing seamed fine. It drove fine I couldn't tell there was anything wrong but my brother in law said he could hear a metal on metal sound when I was in the air and on the rev limiter. I took it back to the house removed the pump to fined some wear on my ss wear ring. I real don't think I sucked anything up. It looks like the impeller is making slight contact with just the bottom of the wear ring. When I installed the pump I torqued it to speck. The pump bearing doesn't seam to have any play in it. I will get a pick of it next time I go up to the lake. I don't know what is causing this any input would be a big help


  2. #2
    I finally got ONE!!! ;) RXT-260-DOO's Avatar
    Join Date
    Jun 2011
    Location
    Hot Sulphur Springs, CO
    Posts
    295
    +1
    26
    The only thing I can think of is drive shaft alignment. ???

  3. #3

    Join Date
    May 2014
    Location
    San Antonio texas
    Posts
    114
    +1
    11
    I don't think it is a drive shaft issue because the drive shaft free floats on the impeller end. It is supported by the pump bearing

  4. #4
    I finally got ONE!!! ;) RXT-260-DOO's Avatar
    Join Date
    Jun 2011
    Location
    Hot Sulphur Springs, CO
    Posts
    295
    +1
    26
    Yes, but when attached to the pump, the pump and motor are stationary. Pump is not adjustable, motor is.

  5. #5

    Join Date
    May 2014
    Location
    San Antonio texas
    Posts
    114
    +1
    11
    That is a good point. That's the kind of help I am looking for. Do you then think that under load the engine is flexing the motor mounts causing a bind on the drive shaft? I don't feel any thing when riding. Do you think it could be a small amount of play in the pump bearing even though it feels tight

  6. #6

    Join Date
    May 2014
    Location
    San Antonio texas
    Posts
    114
    +1
    11
    I am starting to think that the toque of the motor is flexing the pump bearing down ward causing it to hit the bottom of the wear ring

  7. #7
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    It's just a cheap plastic liner ... The 4 tec liner are much better ...

  8. #8
    Did you put a new impeller on also?

  9. #9

    Join Date
    May 2014
    Location
    San Antonio texas
    Posts
    114
    +1
    11
    Yes it is new and it doesn't seam to hit when I just spin it it only seams to hit under power

  10. #10

    Join Date
    May 2014
    Location
    San Antonio texas
    Posts
    114
    +1
    11
    Slasher what is just a cheep plastic liner? I have a stainless steal wearing. Are you taking about the bearing or something in the pump

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 250X Pump Impeller Clearances
    By kman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 04-20-2009, 07:32 PM
  2. need some help/ impeller damage
    By zerowake in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-27-2009, 11:39 PM
  3. HELP, impeller
    By craigrs in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-29-2008, 06:28 PM
  4. Need some help! Impeller touching wear ring
    By awague2 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-02-2008, 04:20 PM
  5. impeller clearance tool... use computer paper!!!
    By cue03 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-16-2007, 08:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •