Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    john07ex's Avatar
    Join Date
    Jul 2007
    Location
    Orlando, Fl
    Posts
    475
    +1
    26

    2014 GTX depth finder

    My friend just bought a brand new GTX limited 215. The depth finder isnt working. Can someone tell me how to troubleshoot it? We don't want to take it back to the dealer and drop it off and wait. PLUS we dont trust dealers much anyways.


  2. #2

    Join Date
    Feb 2006
    Location
    Cape May
    Posts
    626
    +1
    17
    it may have to be activated with budds or candoo?

  3. #3
    john07ex's Avatar
    Join Date
    Jul 2007
    Location
    Orlando, Fl
    Posts
    475
    +1
    26
    Shouldnt it be done from factory sine its standard on Limited?

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    If it is standard equimpment, then something must be wrong with it. The newer skis are plug and play, no dealer needed to activate. I wouid look at the fuse first.

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Wait a minute. Are you scrolling through the menu, to bring it up on the display?

  6. #6
    john07ex's Avatar
    Join Date
    Jul 2007
    Location
    Orlando, Fl
    Posts
    475
    +1
    26
    Its in my garage ill test again when i get home. Where is the main fuse block?

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by john07ex View Post
    Its in my garage ill test again when i get home. Where is the main fuse block?
    Back starboard access compartment.

  8. #8

    Join Date
    Feb 2009
    Location
    Lake Norman, NC
    Posts
    42
    +1
    1
    I believe ski needs to be in water to work.
    When dealer added a depth sounder to my new 2013 GTX, it did not work. They had to add another fluid pouch (what ever it's called) under the transducer - it now works fine.

  9. #9
    RGUN's Avatar
    Join Date
    Aug 2013
    Location
    Work: GTA ------------ ----------------- Play: Georgian Bay
    Posts
    551
    +1
    53
    Quote Originally Posted by jjjj View Post
    I believe ski needs to be in water to work.
    When dealer added a depth sounder to my new 2013 GTX, it did not work. They had to add another fluid pouch (what ever it's called) under the transducer - it now works fine.
    It does need to be in the water to generate a depth reading, but if you power up out of the water you can still pull up the depth finder display, it will just read "--"

  10. #10
    john07ex's Avatar
    Join Date
    Jul 2007
    Location
    Orlando, Fl
    Posts
    475
    +1
    26
    Yes that is what is shows in the water the two dashes.

    The fuse looks good. It is on top of the battery in the rear right tray on swim platform. Where is the transducer located?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2014 GTX is 260 Stock Depth finder
    By Sabby in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 04-14-2015, 01:47 PM
  2. 2014 GTX Limited Depth Finder Issue
    By Hwy115 in forum Sea Doo Open Discussion
    Replies: 31
    Last Post: 09-22-2014, 09:56 AM
  3. 2003 4-Tec GTX Depth Finder Mounting Location
    By thompsdw in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-21-2014, 05:18 PM
  4. 2004 GTX Depth Finder
    By HoverRL in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 03-11-2012, 08:21 AM
  5. Depth finder on a 03 GTX SC
    By eckersjc2 in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-01-2007, 12:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •