Results 1 to 10 of 10
  1. #1
    hudsta's Avatar
    Join Date
    Sep 2008
    Location
    MK United Kingdom
    Posts
    163
    +1
    1

    overheating on 300x 2012

    Just wondering if anyone else has had overheating issues from clogged intercooler, i cleaned it down around 3 hours ago as it was gunked up really bad and had started bogging , done a 40 odd mile run out and seemed to be running ok with good boost but took out to race and lost top end as it got warmer and kicked into limp mode in 3rd 30 minute race , i have checked all the cooling hoses and am going to do additional catchcan but just wondering if this alone would cause enough overheat to send into limp mode or if there is probably another issue aswell?


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    so what was the overheat code that would help.

  3. #3
    hudsta's Avatar
    Join Date
    Sep 2008
    Location
    MK United Kingdom
    Posts
    163
    +1
    1
    It just flashed "heat" , not sure how to retrieve a code from it ? Does it store in memory ?

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Nope not for you to read later

  5. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Click image for larger version. 

Name:	uploadfromtaptalk1401791810140.jpg 
Views:	92 
Size:	31.1 KB 
ID:	331124 have you checked these

  6. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Why do additional catchcan just replace it with a 13.5 model one

  7. #7
    hudsta's Avatar
    Join Date
    Sep 2008
    Location
    MK United Kingdom
    Posts
    163
    +1
    1
    Quote Originally Posted by nicjak View Post
    Why do additional catchcan just replace it with a 13.5 model one
    Yeah will be fitting 13.5 one and using existing one also as I was told alone it doesn't fully resolve issue,
    Can't read that table off my phone but will have a look later, thanks

  8. #8
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    I think your on the wrong track with adding an extra can, but your choice

  9. #9
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Do yourself a favour and load the manual on your phone

  10. #10
    hudsta's Avatar
    Join Date
    Sep 2008
    Location
    MK United Kingdom
    Posts
    163
    +1
    1
    yeah i have it on pc, shoulda just checked it myself ,thanks though
    oil is getting changed, think i got some water in where filter drain plug had come off and is looking a bit dodgey.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva Speed Control Override Module on 300x
    By lasportsmn in forum Kawasaki Tech Tips and Info
    Replies: 30
    Last Post: 07-30-2017, 09:02 PM
  2. fog supercharger on 300x after every ride.
    By salvage101 in forum Kawasaki How To & FAQs
    Replies: 15
    Last Post: 10-20-2011, 03:34 PM
  3. 1st time out w/ Riva waterbox and free flow exhaust on 300x
    By cmexeqtu2 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 06-30-2011, 04:14 PM
  4. how often to fog supercharger on 300x ultra????
    By cmexeqtu2 in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 05-25-2011, 06:49 AM
  5. 2001 Virage TX overheating on hose
    By skiversinc in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-17-2008, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •