Results 1 to 5 of 5
  1. #1
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163

    95XP800 resurrection

    I'm in the process of helping a buddy resurrect his 95XP800 when we ran into a big snag. Got out on the water and it was running like a champ with the new motor. Got across the lake and it does. Open the seat and you can smell hot electrical. What I found was that the plug that goes to the stator from the gray box got a little toasty and burnt off the pins. Now the question is, is there anything I need to fix before I go replacing parts? I know I'm going to need a new line from the gray box to the stator cover and a new plug for the stator cover to the pickup. Could this be an issue with the magneto charging system?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	42 
Size:	27.1 KB 
ID:	331106  


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Would a lack of electrical grease cause this?

  3. #3
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83
    Well thats not normal, I think if you just replace it, it will toast again. You mentioned new motor, what all was done and who did the stator cover etc? You might want to take the cover off and see whats going on in there, maybe wires are touching, water etc.

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by surferd15 View Post
    Well thats not normal, I think if you just replace it, it will toast again. You mentioned new motor, what all was done and who did the stator cover etc? You might want to take the cover off and see whats going on in there, maybe wires are touching, water etc.
    yes, im fixing the problem and not replacing parts. The local stealership did all the "warranty" work. they aren't known to do a good job IMO. This is not the original motor and im not certain what was swapped from the 785 motor to this 787 or if its just a complete create motor. from what it looks like it was a complete new silver motor, but I will check. Im thinking water but wont find out till I pull the motor. im wondering if the stator shorted, or the voltage regulator screwed up IDK. im fishing for answers at this point till I tear into it.

  5. #5
    785xp's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Posts
    897
    +1
    7
    I wouldn't pull the motor, just take off the front cover and check the condition of stator and magneto.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Original RXP/GPR Engine Swap (The Resurrection of Vigilante)
    By JFizzleJR in forum Conversion PWC Performance Skis
    Replies: 405
    Last Post: 08-25-2010, 03:15 PM
  2. steps to resurrecting a gp
    By ppkarnezis in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 01-27-2009, 11:06 AM
  3. 95XP800 waterbox???
    By northshorerider in forum 2-Stroke Performance
    Replies: 43
    Last Post: 01-25-2009, 12:35 AM
  4. Wanted: 95XP800 Hood Or any X4 Hood
    By madtork in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 10-29-2008, 11:00 AM
  5. 96GSX & 95XP800 parts for sale
    By hardavmotcyc66 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 09-17-2008, 10:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •