Page 1 of 9 1 2 3 ... LastLast
Results 1 to 10 of 87
  1. #1
    waz480's Avatar
    Join Date
    Oct 2012
    Location
    Meopham, United Kingdom
    Posts
    91
    +1
    5

    Advice on prop and Motec please

    I have listed the spec of my 2012 RXP-X below and would like to know what prop and/or other mods you guys would recommend please ,
    It's used in the sea and very rare in flat water but a prop capable of a descent top speed would be nice , My am running a Solas SRX-CD-15/22R at the moment but have been told its too big ? , My RPM limit is 9000 and my whole jet system is stock a part from prop and Stainless wear ring,
    Thanks in advance



    ET 70-145 Race edition S/C LE,Injector Dynamics 1000cc,Danny fuel rail,MoTeC M130,MoTec LTC,LSU 4.9 Oxygen Sensor,Riva front air intake kit flame arrestor air box removed,Aeromotive 340 LPH Fuel Pump,Ported head,Light cam sprocket,629 cam,Supertech light valves,Supertech valve springs,Les titan retain,ARP head stud,Rad4 torque plate,Block guard,Riva waterbox,Full Riva hull exhaust,Dukes 1000 BHP Intercooler,Stainless wear ring,Solas SRX-CD-15/22R,R&D pump seal,R&D Aquavein grate,160 deg stat,

    Sorry i should of said when it had the Les 8800rpm ecu , c kit and 48 injectors it would rev and go great with the same prop, Then i fitted the ET 70-145 Race edition S/C LE,Injector Dynamics 1000cc,Danny fuel rail,MoTeC M130,MoTec LTC,LSU 4.9 Oxygen Sensor all at the same time , set fuel pressure 58 psi as Nils said now when i run it wont rev past 7900 rpm same prop though out by the way , I checked the slip ,upped the fuel pressure to 60 then 62 psi still wont rev and is so rich now you can write your name in the soot in the exhaust, Then just to make matters worse my laptop running windows xp wont connect to the Motec it used to when i first fitted the motec , I tried a different laptop running windows 7 that will connect for a few seconds then disconnect before i can get the log off it , I have checked the connections and cable all looks okay ? , I have tried phoning Nils but never any one there , I know he is a busy man and it is not his fault so please dont think i am dissing him, I know Motec is the best ecu you can buy but i wish i had never bought it now , I dont know enough about it to sort it on my own and here in the UK there is no support also i have IBR problems god knows if it as anything to do with the motec , also i have faults come up on the laptop when it will work with the laptop for a few seconds
    1: exhaust lamba external diagnostic "low fault"
    2: Jet trim sensor diagnostic "hight fault
    Fault code P1550 on the dash,
    I know motec is the way forward when it's set up correctly but the lack of support in the UK , My lack of knowledge with Motec , No communication with my laptop for logging, i have not been able to use my ski of over a month now in the very short summer we have in the UK has left me a little disappointed to say the least,
    Sorry if this has turned into a rant but i sold my old set up to pay for my new parts so i cant even go back ,
    I thought the problem might be the prop as i am stuck to try anything else,
    I have tried Google and webanars but could not find anything that was helpful
    Last edited by waz480; 06-03-2014 at 02:31 PM.


  2. #2
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    please state your current wide open throttle RPMS

    What speeds are you seeing?

  3. #3
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    I taught 2012 needed SRZ props...

  4. #4
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Quote Originally Posted by spouk3 View Post
    I taught 2012 needed SRZ props...
    Yes

  5. #5
    It would be a real advantage to post a half hour or so data log with you running the ski hard in all sorts of water conditions. With that log, we can see just how the existing prop is doing.

    15-22 sounds tall. It all depends what you feel comfortable with regarding boost, rpm and level of noise.

    Andy

  6. #6
    ATNryan's Avatar
    Join Date
    Apr 2012
    Location
    River Crew CT
    Posts
    695
    +1
    75
    Hmmm surprised your rpms and speed aren't good. I'm spinning my 15/22 to 8600 without a ported head and a much smaller charger. I would think u would be close to your 9k limiter. Gonna follow this thread to see what the deal is.

  7. #7
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Nice setup! I would keep the 15/22 for the really cool weather and simply get a 15/20. Your water temps and air temps are much lower than most of us in the lower 48 states.

    IMO, I would shoot for 8800 rpms at WOT.

  8. #8
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455
    Post up your log

  9. #9
    waz480's Avatar
    Join Date
    Oct 2012
    Location
    Meopham, United Kingdom
    Posts
    91
    +1
    5
    Comment duplicated so removed
    Last edited by waz480; 06-03-2014 at 02:35 PM.

  10. #10

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    I would keep the impeller you have, since you say it was on spot with the less HP setup-- may have to add some pitch or raise your rev limiter actually once you find your problems. You have issues with you tune, setup and or ski's stock parts that need to be addressed before trying different impellers.

Page 1 of 9 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Advice on [email protected] please
    By osubrenden in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-21-2013, 06:14 AM
  2. advice on pitch and rpms with skat trak?
    By prostocker in forum Yamaha PWC Performance (4-stroke)
    Replies: 16
    Last Post: 02-08-2013, 06:21 PM
  3. 1999 Ultra 150. Advice on pump and impeller please!
    By HydroStream6 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-28-2012, 10:06 AM
  4. NEED ADVICE on RXT-X mods please
    By turbocycle in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-23-2008, 07:25 PM
  5. Need advice on prop selection
    By R88ory RXP in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-19-2008, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •