Results 1 to 6 of 6
  1. #1
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1

    05 15F starting problem

    Ski turns over but won't start. Took fuel rail off and had no gas in there. Could it be the fuel pump?


  2. #2
    MPG350's Avatar
    Join Date
    Apr 2014
    Location
    Trinity, FL
    Posts
    131
    +1
    7
    Possible I say start with the easy things maybe try new plugs first. I just purchased a used 15F and it started much better
    with new plugs even though the old ones looked good.


    EDIT didn't see the part about taking fuel rail off and no gas

  3. #3
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    Quote Originally Posted by MPG350 View Post
    Possible I say start with the easy things maybe try new plugs first. I just purchased a used 15F and it started much better
    with new plugs even though the old ones looked good.


    EDIT didn't see the part about taking fuel rail off and no gas
    Yea first thing was that. I'm thinking is the fuel pump. Was hitting the start with the fuel rail out and had no gas going though

  4. #4
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Houston, TX
    Posts
    570
    +1
    51
    Probably fuel pump, but follow Sean's guide to diagnose the problem:

    http://www.greenhulk.net/forums/showthread.php?t=186939


    -Greg

  5. +1 by:


  6. #5
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    Quote Originally Posted by boudin View Post
    Probably fuel pump, but follow Sean's guide to diagnose the problem:

    http://www.greenhulk.net/forums/showthread.php?t=186939


    -Greg
    Thanks. It was the fuel pump

  7. #6
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    Figured it out. It was the fuel pump.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 3D Starting Problems. Help
    By rtkylake in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-22-2010, 04:29 PM
  2. 15f starting problems
    By mirror in forum Kawasaki Open Discussion
    Replies: 11
    Last Post: 08-25-2009, 03:56 PM
  3. 15f starting problem
    By DONALDBUCHANAN in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-28-2007, 08:31 AM
  4. 05 RXP Starting problems
    By Cody Townsend in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 05-09-2006, 05:51 PM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •